summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-contacts
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-contacts')
-rw-r--r--gnome-extra/gnome-contacts/Manifest2
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.14.2.ebuild65
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.16.2.ebuild70
-rw-r--r--gnome-extra/gnome-contacts/metadata.xml5
4 files changed, 142 insertions, 0 deletions
diff --git a/gnome-extra/gnome-contacts/Manifest b/gnome-extra/gnome-contacts/Manifest
new file mode 100644
index 000000000000..a89a8209003f
--- /dev/null
+++ b/gnome-extra/gnome-contacts/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-contacts-3.14.2.tar.xz 749320 SHA256 9a21171cb7a08299a937b7d940e362411b08cc8adbd248d5a1f59107f5d2925d SHA512 8b05f8313f5448f8922826759aa4eac9d5f64a3ef11cf49fae08572c7f19e9ce420fdf41e61451399bbc7487047ab53ab32a14b6dee22889a6624db313022c70 WHIRLPOOL 1d094fc0023bf44979bd730aa5c3f5ab876112cd1eddf7586dfcddbf822c083e60b142727726f26cdd473f30ec6ee0d93c8d414c99a7ff14a38cf92f0c76ce17
+DIST gnome-contacts-3.16.2.tar.xz 767720 SHA256 fb625a40fe915d866625a7d688c9a3b454d198c9474ce2efc3979f2b0d1687e7 SHA512 287f81be4452eb2fff6f0b3ab1b00aa4cb8fac1157f62dcd6a9f61928151617ca69f0b6463c83c69ad4d85e9656c49d65eb603f8f39d036bd7091353dc3b9ab7 WHIRLPOOL d633db8776914f287030b0ee2b473e694513b974fc47b1fcb93fedcb657438eda6fef998e971553e9e4071a9961102930ed02304c1847fa93fb3e01e85e92b28
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.14.2.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.14.2.ebuild
new file mode 100644
index 000000000000..edb2970b1aa3
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.14.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="v4l"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+VALA_DEPEND="
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.9.6
+ dev-libs/folks[vala(+)]
+ gnome-base/gnome-desktop[introspection]
+ gnome-extra/evolution-data-server[vala]
+ net-libs/telepathy-glib[vala]
+ x11-libs/libnotify[introspection]
+"
+# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+RDEPEND="
+ >=dev-libs/folks-0.9.5:=[eds,telepathy]
+ >=dev-libs/glib-2.37.6:2
+ >=dev-libs/libgee-0.10:0.8
+ >=gnome-extra/evolution-data-server-3.5.3:=[gnome-online-accounts]
+ >=gnome-base/gnome-desktop-3.0:3=
+ net-libs/gnome-online-accounts
+ >=net-libs/telepathy-glib-0.17.5
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libnotify:=
+ >=x11-libs/gtk+-3.12:3
+ x11-libs/pango
+ v4l? ( >=media-video/cheese-3.5.91:= )
+"
+DEPEND="${RDEPEND}
+ ${VALA_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Regenerate the pre-generated C sources, bug #471628
+ if ! use v4l; then
+ touch src/*.vala
+ fi
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_with v4l cheese)
+}
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.16.2.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.16.2.ebuild
new file mode 100644
index 000000000000..3da430dca241
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.16.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="v4l"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+VALA_DEPEND="
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.9.6
+ dev-libs/folks[vala(+)]
+ gnome-base/gnome-desktop[introspection]
+ gnome-extra/evolution-data-server[vala]
+ net-libs/telepathy-glib[vala]
+ x11-libs/libnotify[introspection]
+"
+# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+RDEPEND="
+ >=dev-libs/folks-0.9.5:=[eds,telepathy]
+ >=dev-libs/glib-2.37.6:2
+ >=dev-libs/libgee-0.10:0.8
+ >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
+ >=gnome-base/gnome-desktop-3.0:3=
+ media-libs/clutter-gtk:1.0
+ media-libs/libchamplain:0.12
+ net-libs/gnome-online-accounts
+ >=net-libs/telepathy-glib-0.17.5
+ >=sci-geosciences/geocode-glib-3.15.3
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libnotify:=
+ >=x11-libs/gtk+-3.12:3
+ x11-libs/pango
+ v4l? ( >=media-video/cheese-3.5.91:= )
+"
+DEPEND="${RDEPEND}
+ ${VALA_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Regenerate the pre-generated C sources, bug #471628
+ if ! use v4l; then
+ touch src/*.vala
+ fi
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_with v4l cheese)
+}
diff --git a/gnome-extra/gnome-contacts/metadata.xml b/gnome-extra/gnome-contacts/metadata.xml
new file mode 100644
index 000000000000..6e0e2ecb48ca
--- /dev/null
+++ b/gnome-extra/gnome-contacts/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>