summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2019-07-04 21:51:54 -0400
committerSobhan Mohammadpour <sobhan@gentoo.org>2019-07-04 21:53:13 -0400
commit1c751b43dac8ce32aa1ac38237cb61f5c5cc8118 (patch)
tree3cb84700c4e7d0c2a8605b3ba7c4c9662d931b1d /gnome-extra/gnome-calculator
parentdev-libs/libgweather: 3.32.1 → 3.32.2 (diff)
downloadgentoo-1c751b43dac8ce32aa1ac38237cb61f5c5cc8118.tar.gz
gentoo-1c751b43dac8ce32aa1ac38237cb61f5c5cc8118.tar.bz2
gentoo-1c751b43dac8ce32aa1ac38237cb61f5c5cc8118.zip
gnome-extra/gnome-calculator: 3.30.1 → 3.32.2
Package-Manager: Portage-2.3.67, Repoman-2.3.14 RepoMan-Options: --force Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-calculator')
-rw-r--r--gnome-extra/gnome-calculator/Manifest1
-rw-r--r--gnome-extra/gnome-calculator/gnome-calculator-3.32.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/gnome-calculator/Manifest b/gnome-extra/gnome-calculator/Manifest
index f4a18199fb2f..ad3fc32a4eca 100644
--- a/gnome-extra/gnome-calculator/Manifest
+++ b/gnome-extra/gnome-calculator/Manifest
@@ -1 +1,2 @@
DIST gnome-calculator-3.30.1.tar.xz 1070308 BLAKE2B dca8e16f754d7ae7ac3371dbe65fcaacf51c251d377cc696c7c9a9ca6b4d9c0f6431acd06c3091e3d3e0f468cc599953452cbbe4de33473e365425ca3add602f SHA512 4c909f36d1e6ff594b9ab76419a6b50962cf4b5de606c4996d311e5ef6511a20d5c3b310919b271b1a0120ed6a0794644faf5a390d94b71ec6bb89883d498565
+DIST gnome-calculator-3.32.2.tar.xz 947096 BLAKE2B 7c511e4d22971b008587aaa9ee7a44bfa663b663ebaddd6b5d4426f673e0f8975506c3b6aaba2781e3ccbe9ab7b9eb9b9d876c1b8acae9e14b195bfbeb207c42 SHA512 ef30ddad8b68367f71c2b894f041affe2b88c8aa90ad40d6128d03e0dc4871fd57d632809a365b14bac0b53dad37a73df564d237b8f45d4c42c38e118cb26de1
diff --git a/gnome-extra/gnome-calculator/gnome-calculator-3.32.2.ebuild b/gnome-extra/gnome-calculator/gnome-calculator-3.32.2.ebuild
new file mode 100644
index 000000000000..a4ff4383308a
--- /dev/null
+++ b/gnome-extra/gnome-calculator/gnome-calculator-3.32.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+# gtksourceview vapi definitions in dev-lang/vala itself are too old, and newer vala removes them
+# altogether, thus we need them installed by gtksourceview[vala]
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=x11-libs/gtk+-3.19.3:3
+ x11-libs/gtksourceview:4[vala]
+ >=net-libs/libsoup-2.42:2.4
+ dev-libs/libxml2:2
+ dev-libs/mpc:=
+ dev-libs/mpfr:0=
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}