summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-11-10 10:12:59 +0100
committerDavid Seifert <soap@gentoo.org>2024-11-10 10:12:59 +0100
commit946db7074cc787765be1ecef42140931fda47192 (patch)
tree74980123445721cb71d252b6867f382decd7d588 /games-util
parentdev-libs/asmjit: add 2024.10.25, 9999 (diff)
downloadgentoo-946db7074cc787765be1ecef42140931fda47192.tar.gz
gentoo-946db7074cc787765be1ecef42140931fda47192.tar.bz2
gentoo-946db7074cc787765be1ecef42140931fda47192.zip
games-util/grfcodec: add 6.1.0
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/grfcodec/Manifest1
-rw-r--r--games-util/grfcodec/grfcodec-6.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/games-util/grfcodec/Manifest b/games-util/grfcodec/Manifest
index 06a4a62fcc28..ff37c9457ef7 100644
--- a/games-util/grfcodec/Manifest
+++ b/games-util/grfcodec/Manifest
@@ -1,2 +1,3 @@
DIST grfcodec-6.0.6_p20210310.tar.gz 205795 BLAKE2B 24d803e208b2fc465ae71611c0c0fb2737bfa8c5a28375bc08a6220581d7b07bb2f2a390e2ddb7f4beb8a80951862473919d41bce83364af70b6dc646f0f3f8e SHA512 10f4ec28c69d87e397f0fb5b497dbefce8fcd826731d3a0a864cbbd333b7df188ab0087445644ad245aeff65a8b6563dfdfa657ac1a2248e56e296c01f7d58a8
DIST grfcodec-6.0.6_p20230811.tar.gz 205324 BLAKE2B 00d36b6785d00edec061cc0f0a695225a78c487bc66c4521f0f3da1050304bc382ed78d1df8dff8602b35b167505388ad993c46f01ac39960c131a6f5c7264eb SHA512 95a883636720ad1fdd0a2e17cba60b6cde15b5fe0337cfe2330db75d60e9a2bdb1dea3c06bb8f8acace8989b6abaf6d1845b30c5bc5f6c76f34e5aa76f36ddd4
+DIST grfcodec-6.1.0-source.tar.xz 170688 BLAKE2B e9ce6ca4984e319abd5c1fd53473b1257b2b98b0948b5bef5e6275e29b50243981bf7fc837b190b37b2bb12d2ac9aecbb8595150eedb029f1d7ae64053668475 SHA512 9129e0f38b151e11c90585e0fe966e042ad08ec90f800ee80f749865aed6c72c733639b8d02ecd613409f2a0ae6d1f72fa1d3524f7c450a0f06ff42ee170f16f
diff --git a/games-util/grfcodec/grfcodec-6.1.0.ebuild b/games-util/grfcodec/grfcodec-6.1.0.ebuild
new file mode 100644
index 000000000000..9418544f1b63
--- /dev/null
+++ b/games-util/grfcodec/grfcodec-6.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
+HOMEPAGE="https://github.com/OpenTTD/grfcodec"
+SRC_URI="https://github.com/OpenTTD/grfcodec/releases/download/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="media-libs/libpng:="
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+PATCHES=(
+ # Bug #894648
+ "${FILESDIR}"/${PN}-6.0.6_p20230811-no-fortify-source.patch
+)
+
+src_install() {
+ dobin "${BUILD_DIR}"/{grfcodec,grfid,grfstrip,nforenum}
+ doman docs/*.1
+ dodoc changelog.txt docs/*.txt
+}