summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/xqf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/xqf')
-rw-r--r--games-util/xqf/Manifest1
-rw-r--r--games-util/xqf/files/xqf-1.0.5-cpu-overrun.patch22
-rw-r--r--games-util/xqf/files/xqf-1.0.5-underlink.patch10
-rw-r--r--games-util/xqf/files/xqf-1.0.5-zlib-1.2.5.1-compile-fix.patch11
-rw-r--r--games-util/xqf/metadata.xml8
-rw-r--r--games-util/xqf/xqf-1.0.5.ebuild43
6 files changed, 95 insertions, 0 deletions
diff --git a/games-util/xqf/Manifest b/games-util/xqf/Manifest
new file mode 100644
index 000000000000..53ccf87ef979
--- /dev/null
+++ b/games-util/xqf/Manifest
@@ -0,0 +1 @@
+DIST xqf-1.0.5.tar.gz 742183 SHA256 ee0ab9a40516c55d9f00e65ab06b1c6669f0de858bc8a7416e6993a76c0d9b67 SHA512 2e571ed43da9ff440b6b13473ac618d2d87634a9571f892a11a7269e39518f74bf54e39e1508f734cb06e336f99cc2d3b9427666c93ff1ad8ec2b37ae6363035 WHIRLPOOL d65f896cfdbf28b4f1647dfe2ec54c68f356fa3d5e393e17b2c50145a0738fc3ff96a36481eb86b7dad96983ea66f311215a0812bdf72940a27bc0f0ff9d6cc4
diff --git a/games-util/xqf/files/xqf-1.0.5-cpu-overrun.patch b/games-util/xqf/files/xqf-1.0.5-cpu-overrun.patch
new file mode 100644
index 000000000000..567d82a6a6c2
--- /dev/null
+++ b/games-util/xqf/files/xqf-1.0.5-cpu-overrun.patch
@@ -0,0 +1,22 @@
+diff -aburN xqf.orig/src/launch.c xqf/src/launch.c
+--- xqf.orig/src/launch.c 2009-10-13 11:58:24.000000000 +0200
++++ xqf/src/launch.c 2009-10-13 11:59:35.000000000 +0200
+@@ -168,13 +168,17 @@
+
+ res = read (fd, cl->buffer + cl->pos, CLIENT_ERROR_BUFFER - 1 - cl->pos);
+
+- if (res <= 0) { /* read error or EOF */
++ if (res < 0) { /* read error or EOF */
+ if (errno == EAGAIN || errno == EWOULDBLOCK)
+ return;
+
+ client_detach (cl);
+ return;
+ }
++ else if (res == 0) {
++ client_detach (cl);
++ return;
++ }
+
+ if (cl->pos + res == CLIENT_ERROR_BUFFER - 1) {
+ tmp = &cl->buffer[CLIENT_ERROR_BUFFER - 1];
diff --git a/games-util/xqf/files/xqf-1.0.5-underlink.patch b/games-util/xqf/files/xqf-1.0.5-underlink.patch
new file mode 100644
index 000000000000..523204cd9247
--- /dev/null
+++ b/games-util/xqf/files/xqf-1.0.5-underlink.patch
@@ -0,0 +1,10 @@
+--- src/Makefile.in.old 2011-06-14 21:32:28.929746563 +0200
++++ src/Makefile.in 2011-06-14 21:32:46.567818865 +0200
+@@ -311,6 +311,7 @@
+ $(GEOIP_LIB) \
+ $(PACKAGE_LIBS) \
+ $(GDK_PIXBUF_LIBS) \
++ -lX11 -ldl \
+ -lz
+
+ xqf_LDFLAGS = -Wl,-rpath,$(pkglibdir) -Wl,--export-dynamic -Wl,--version-script=$(top_srcdir)/src/xqf.map
diff --git a/games-util/xqf/files/xqf-1.0.5-zlib-1.2.5.1-compile-fix.patch b/games-util/xqf/files/xqf-1.0.5-zlib-1.2.5.1-compile-fix.patch
new file mode 100644
index 000000000000..9bd433b3b27e
--- /dev/null
+++ b/games-util/xqf/files/xqf-1.0.5-zlib-1.2.5.1-compile-fix.patch
@@ -0,0 +1,11 @@
+--- xqf-1.0.5/src/zip/ioapi.h
++++ xqf-1.0.5/src/zip/ioapi.h
+@@ -6,6 +6,8 @@
+ Copyright (C) 1998-2003 Gilles Vollant
+ */
+
++#define OF(x) x
++
+ #ifndef _ZLIBIOAPI_H
+ #define _ZLIBIOAPI_H
+
diff --git a/games-util/xqf/metadata.xml b/games-util/xqf/metadata.xml
new file mode 100644
index 000000000000..2d7c8b9fdee9
--- /dev/null
+++ b/games-util/xqf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">xqf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/xqf/xqf-1.0.5.ebuild b/games-util/xqf/xqf-1.0.5.ebuild
new file mode 100644
index 000000000000..626d756d5462
--- /dev/null
+++ b/games-util/xqf/xqf-1.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A server browser for many FPS games (frontend for qstat)"
+HOMEPAGE="http://www.linuxgames.com/xqf/"
+SRC_URI="mirror://sourceforge/xqf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE="bzip2 geoip nls"
+
+RDEPEND="x11-libs/gtk+:2
+ >=games-util/qstat-2.11
+ nls? ( virtual/libintl )
+ geoip? ( dev-libs/geoip )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+# bug #288853
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-cpu-overrun.patch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-zlib-1.2.5.1-compile-fix.patch
+ sed -i \
+ -e '/Icon/s/.png//' \
+ xqf.desktop.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable geoip) \
+ $(use_enable bzip2) \
+ --enable-gtk2
+}