summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/deutex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/deutex')
-rw-r--r--games-util/deutex/Manifest1
-rw-r--r--games-util/deutex/deutex-4.4.0.ebuild32
-rw-r--r--games-util/deutex/files/deutex-4.4.0-64bit.patch13
-rw-r--r--games-util/deutex/files/deutex-4.4.0-makefile.patch29
-rw-r--r--games-util/deutex/files/deutex-4.4.0-ovflfix.patch11
-rw-r--r--games-util/deutex/metadata.xml5
6 files changed, 91 insertions, 0 deletions
diff --git a/games-util/deutex/Manifest b/games-util/deutex/Manifest
new file mode 100644
index 000000000000..acdc4e62e7fa
--- /dev/null
+++ b/games-util/deutex/Manifest
@@ -0,0 +1 @@
+DIST deutex-4.4.0.tar.gz 215945 SHA256 e87ff2984c6555f30408ee7aa4e6461aac6f1d3d0a1e21b4e12a797a057ba3b7 SHA512 fc9aaf399bc9d8ea812102decdf6b3c6d5f4c4a69e925e02fe0e75fa8dc9e54ad36afc352e83819ba13b9ae5dda90bb65c1856825c3ee17c7bd370909b866fb5 WHIRLPOOL c3e86d74a55a65ca0645e9a1ca9de9f580eee3176e5fdff889964b7e34cda2662a43cf1586829b50277bde6cd03584b8dbf38e5b56c4af3e7d7ee39f41257320
diff --git a/games-util/deutex/deutex-4.4.0.ebuild b/games-util/deutex/deutex-4.4.0.ebuild
new file mode 100644
index 000000000000..3e45418ba327
--- /dev/null
+++ b/games-util/deutex/deutex-4.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A wad composer for Doom, Heretic, Hexen and Strife"
+HOMEPAGE="http://www.teaser.fr/~amajorel/deutex/"
+SRC_URI="http://www.teaser.fr/~amajorel/deutex/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ HPND"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin deusf deutex
+ doman deutex.6
+ dodoc CHANGES README TODO
+}
diff --git a/games-util/deutex/files/deutex-4.4.0-64bit.patch b/games-util/deutex/files/deutex-4.4.0-64bit.patch
new file mode 100644
index 000000000000..b5028cd4ffbd
--- /dev/null
+++ b/games-util/deutex/files/deutex-4.4.0-64bit.patch
@@ -0,0 +1,13 @@
+diff --git a/src/deutex.h b/src/deutex.h
+index 0a26df5..7af321c 100644
+--- a/src/deutex.h
++++ b/src/deutex.h
+@@ -31,7 +31,7 @@ Place, Suite 330, Boston, MA 02111-1307, USA.
+ #define DeuSF for DOS .EXE Unix Linux OS/2
+ *********************************************/
+
+-#if defined (__alpha) /*__ALPHA__ for Alpha processor?*/
++#if defined (__alpha) || defined (__x86_64__) /*__ALPHA__ for Alpha processor?*/
+ /*long = int64 on a 64bit processor*/
+ typedef char Int8;
+ typedef short Int16;
diff --git a/games-util/deutex/files/deutex-4.4.0-makefile.patch b/games-util/deutex/files/deutex-4.4.0-makefile.patch
new file mode 100644
index 000000000000..49265e14f3fb
--- /dev/null
+++ b/games-util/deutex/files/deutex-4.4.0-makefile.patch
@@ -0,0 +1,29 @@
+diff -ru deutex-4.4.0.orig/Makefile deutex-4.4.0/Makefile
+--- deutex-4.4.0.orig/Makefile 1999-12-24 07:50:16.000000000 -0500
++++ deutex-4.4.0/Makefile 2010-03-05 14:53:23.763604022 -0500
+@@ -16,11 +16,6 @@
+
+ PREFIX=/usr/local
+
+-# Compiled by users
+-CFLAGS = -O2
+-CC = cc
+-LDFLAGS =
+-
+ # Compiled by developers
+ DCFLAGS = -g -Wall -Wpointer-arith -Wstrict-prototypes
+ DCC = gcc
+@@ -182,11 +177,11 @@
+ (sleep 1; mkdir -p tmp; touch tmp/_deusf) &
+
+ tmp/_deutex:
+- -mkdir tmp
++ @mkdir tmp 2> /dev/null || true
+ touch $@
+
+ tmp/_deusf:
+- -mkdir tmp
++ @mkdir tmp 2> /dev/null || true
+ touch $@
+
+ install:
diff --git a/games-util/deutex/files/deutex-4.4.0-ovflfix.patch b/games-util/deutex/files/deutex-4.4.0-ovflfix.patch
new file mode 100644
index 000000000000..32a7dce0d97c
--- /dev/null
+++ b/games-util/deutex/files/deutex-4.4.0-ovflfix.patch
@@ -0,0 +1,11 @@
+--- src/sound.c.old 2010-10-27 12:32:28.000000000 +0200
++++ src/sound.c 2010-10-27 12:32:52.000000000 +0200
+@@ -309,7 +309,7 @@
+ if(fread(&headv,sizeof(struct VOCHEAD),1,fp)!=1) ProgError("VOC: can't read header");
+ if(strncmp(VocId,headv.ident,VOCIDLEN)!=0) ProgError("VOC: bad header");
+ if(fseek(fp,headv.block1,SEEK_SET)) ProgError("VOC: bad header");
+- if(fread(&blockv,sizeof(struct VOCHEAD),1,fp)!=1) ProgError("VOC: can't read block");
++ if(fread(&blockv,sizeof(struct VOCBLOCK1),1,fp)!=1) ProgError("VOC: can't read block");
+ if(blockv.type!=1) ProgError("VOC: first block is not sound");
+ datasize= ((blockv.sizeU)<<16)&0xFF0000L;
+ datasize+=((blockv.sizeM)<<8)&0xFF00L;
diff --git a/games-util/deutex/metadata.xml b/games-util/deutex/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/deutex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>