summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-01 19:44:07 +0000
committerSam James <sam@gentoo.org>2021-03-01 19:44:26 +0000
commit8f24ae86e614567ae2ffcd316a2115da31d72214 (patch)
treefc6e65655c175b67aa3585512e7f35775c1a1d76 /games-strategy
parentnet-im/prosody: drop old version (diff)
downloadgentoo-8f24ae86e614567ae2ffcd316a2115da31d72214.tar.gz
gentoo-8f24ae86e614567ae2ffcd316a2115da31d72214.tar.bz2
gentoo-8f24ae86e614567ae2ffcd316a2115da31d72214.zip
games-strategy/0ad: pass JOBS as env var
Closes: https://bugs.gentoo.org/773622 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-0.0.24b_alpha.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild b/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild
index 803df28d90d6..a0468ee4b3e6 100644
--- a/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild
+++ b/games-strategy/0ad/0ad-0.0.24b_alpha.ebuild
@@ -143,7 +143,7 @@ src_compile() {
if use nvtt ; then
cd libraries/source/nvtt || die
elog "Building bundled NVTT (bug #768930)"
- ./build.sh JOBS="-j$(makeopts_jobs)" || die "Failed to build bundled NVTT"
+ JOBS="-j$(makeopts_jobs)" ./build.sh || die "Failed to build bundled NVTT"
cd "${S}" || die
fi
@@ -153,12 +153,16 @@ src_compile() {
# e.g. bug #768840.
cd libraries/source/spidermonkey || die
elog "Building bundled SpiderMonkey (bug #768840)"
- XARGS="${EPREFIX}/usr/bin/xargs" ./build.sh JOBS="-j$(makeopts_jobs)" || die "Failed to build bundled SpiderMonkey"
+ XARGS="${EPREFIX}/usr/bin/xargs" \
+ JOBS="-j$(makeopts_jobs)" \
+ ./build.sh \
+ || die "Failed to build bundled SpiderMonkey"
+
cd "${S}" || die
# Build 0ad itself!
elog "Building 0ad"
- emake -C build/workspaces/gcc verbose=1 JOBS="-j$(makeopts_jobs)"
+ JOBS="-j$(makeopts_jobs)" emake -C build/workspaces/gcc verbose=1
# Build assets
# (We only do this if we're using a snapshot/non-release)