summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/outerspace
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/outerspace')
-rw-r--r--games-strategy/outerspace/Manifest2
-rw-r--r--games-strategy/outerspace/files/outerspace9
-rw-r--r--games-strategy/outerspace/files/outerspace-0.5.68-setup.patch83
-rw-r--r--games-strategy/outerspace/metadata.xml17
-rw-r--r--games-strategy/outerspace/outerspace-0.5.68.ebuild81
5 files changed, 192 insertions, 0 deletions
diff --git a/games-strategy/outerspace/Manifest b/games-strategy/outerspace/Manifest
new file mode 100644
index 000000000000..3ccff6313b89
--- /dev/null
+++ b/games-strategy/outerspace/Manifest
@@ -0,0 +1,2 @@
+DIST outerspace-0.5.68.tar.gz 2249703 SHA256 6ca1ab9f9954821631d150ada07143f84f01eb9eb7773d1656121f657870be01 SHA512 dc2cbebf16fefabcc3356efb496766b90a5eabbf218f085fdc83cf956ca9503e99ef3154e0905c2432a3bf7caabd1f2af585a43397ba368581cd66546fcddc6b WHIRLPOOL cd72366bed75a5eb0a74dfaa8003b47cfa6b5f743b41c427135e965b44f9552bb88aa48203c987fe355824698019d0fe994983c2cfa751679315391fd90aa8f6
+DIST outerspace_0.5.68-0ubuntu1_all.deb 2634188 SHA256 c750f5ab5b124477f59e419f5146548231a48ee3a695a0b7a923628b836e1661 SHA512 9520cf1207a59497d6253b42bc34d580f9b805cf4ae55a5c921082e965892aa67921c4624ea94a5145c911dc2b24a1cca2806c06770ef8d1ded10855fb42666c WHIRLPOOL 137d44d414c3572a7dbbdf16556c499a7132739407407f3f71ee32af2f3671a9c7ec6ae853122cabc466d8963df090fe8b3bfb9881bd643bb498c992304e0e3b
diff --git a/games-strategy/outerspace/files/outerspace b/games-strategy/outerspace/files/outerspace
new file mode 100644
index 000000000000..2a6bbe26dafb
--- /dev/null
+++ b/games-strategy/outerspace/files/outerspace
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+mkdir -p ~/.outerspace
+cd ~/.outerspace || exit 1
+
+ln -sf "@GENTOO_LIBDIR@"/{osc.py,lib,libsrvr} .
+ln -sf "@GENTOO_DATADIR@"/res .
+
+exec python osc.py "$@"
diff --git a/games-strategy/outerspace/files/outerspace-0.5.68-setup.patch b/games-strategy/outerspace/files/outerspace-0.5.68-setup.patch
new file mode 100644
index 000000000000..202c53bc7ee1
--- /dev/null
+++ b/games-strategy/outerspace/files/outerspace-0.5.68-setup.patch
@@ -0,0 +1,83 @@
+--- setup.py
++++ setup.py
+@@ -42,12 +42,7 @@
+
+ # collect data files
+ data_files = []
+-data_files.append(
+- (
+- ".",
+- ["../ChangeLog.txt", "../COPYING", "../README", "../README_CZ"]
+- )
+-)
++
+
+ # resources
+ for root, dirs, files in os.walk('res'):
+@@ -57,16 +52,6 @@
+ pass
+ if files:
+ data_files.append((root, [os.path.join(root, file) for file in files]))
+-
+-data_files.append(
+- (
+- "res/techspec",
+- [
+- "../server/lib/ige/ospace/Rules/techs.spf",
+- "../server/lib/ige/ospace/Rules/Tech.spf",
+- ]
+- )
+-)
+
+ if havePy2Exe:
+ data_files.append((".", ["../updater/update.exe"]))
+@@ -114,10 +99,3 @@
+ **extraArgs
+ )
+
+-# cleanup
+-def onerror(func, path, err):
+- if func is os.remove:
+- os.chmod(path, stat.S_IWRITE)
+- os.remove(path)
+-
+-shutil.rmtree("libsrvr", onerror = onerror)
+--- osc.py
++++ osc.py
+@@ -23,12 +23,36 @@
+ # tweak PYTHONPATH
+ import sys
+ import os
++import errno
+ sys.path.insert(0, "lib")
+
+ for item in ("libsrvr", "../server/lib"):
+ if os.path.exists(item):
+ sys.path.insert(0, item)
+ break
++
++userdir=os.path.expanduser("~/.outerspace")
++resdir=os.path.join(userdir, "res")
++rootresdir="@GENTOO_DATADIR@/res"
++
++if not (os.path.isdir(userdir)):
++ try:
++ os.makedirs(userdir)
++ except:
++ sys.exit("unable to create %s" % userdir)
++
++try:
++ os.symlink(rootresdir, resdir)
++except OSError, e:
++ if e.errno == errno.EEXIST:
++ os.remove(resdir)
++ os.symlink(rootresdir, resdir)
++
++try:
++ os.chdir(userdir)
++except:
++ sys.exit("unable to cd into %s" % userdir)
++
+
+ #configure gc
+ #import gc
diff --git a/games-strategy/outerspace/metadata.xml b/games-strategy/outerspace/metadata.xml
new file mode 100644
index 000000000000..a7960bf9fec7
--- /dev/null
+++ b/games-strategy/outerspace/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+Outer Space is an on-line strategy game which takes place in the dangerous
+universe. You will become powerful commander of many stars, planets, and great
+fleets and will struggle for survival with other commanders.
+
+Outer Space communicates with the server in the same way as your browser, but
+you will need a special client to play it. Using this client you can create an
+account on the server and you can start to explore the world of the Outer Space.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ospace</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-strategy/outerspace/outerspace-0.5.68.ebuild b/games-strategy/outerspace/outerspace-0.5.68.ebuild
new file mode 100644
index 000000000000..a78a4e17f92f
--- /dev/null
+++ b/games-strategy/outerspace/outerspace-0.5.68.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2-utils distutils-r1 games
+
+MY_PN=${PN/outerspace/Outer Space}
+DESCRIPTION="on-line strategy game taking place in the dangerous universe"
+HOMEPAGE="http://www.ospace.net/"
+SRC_URI="mirror://sourceforge/ospace/Client/${PV}/Outer%20Space-${PV}.tar.gz -> ${P}.tar.gz
+ mirror://sourceforge/ospace/Client/${PV}/outerspace_${PV}-0ubuntu1_all.deb"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygame-1.7"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ default
+ unpack ./data.tar.gz
+}
+
+python_install() {
+ distutils-r1_python_install \
+ --install-scripts="${GAMES_BINDIR}" \
+ --install-data="${GAMES_DATADIR}/${PN}" \
+ --install-lib="$(python_get_sitedir)"
+
+ # source tarball is missing files
+ # get them from ubuntu.deb
+ insinto "$(python_get_sitedir)"/ige/ospace/Rules
+ doins "${WORKDIR}"/usr/share/games/outerspace/libsrvr/ige/ospace/Rules/{Tech,techs}.spf
+}
+
+src_prepare() {
+ # fix setup script
+ # rework python start script to avoid shell-wrapper script
+ epatch "${FILESDIR}"/${P}-setup.patch
+
+ sed -i\
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ osc.py || die "sed failed"
+
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ newicon -s 48 res/icon48.png ${PN}.png
+ make_desktop_entry "osc.py" "${MY_PN}"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+
+ einfo
+ einfo "start the game via 'osc.py'"
+ einfo
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}