summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-sports/trigger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-sports/trigger')
-rw-r--r--games-sports/trigger/Manifest1
-rw-r--r--games-sports/trigger/metadata.xml8
-rw-r--r--games-sports/trigger/trigger-0.6.1.ebuild54
3 files changed, 63 insertions, 0 deletions
diff --git a/games-sports/trigger/Manifest b/games-sports/trigger/Manifest
new file mode 100644
index 000000000000..291c41f48996
--- /dev/null
+++ b/games-sports/trigger/Manifest
@@ -0,0 +1 @@
+DIST trigger-rally-0.6.1.tar.bz2 61083932 SHA256 00b22fd290420ed7ed217c3d0bf53b46ad2eaf4c691347f4d3aaca5b1384958a SHA512 9f7e57758ffa61002efff6c7ac4d69f53ef4769651bdfdd21b6a8d101f8fd06ba7dc5998a8877146f50e6124896300e3595b4b5fff4decd53b6555e622de85bf WHIRLPOOL 8b4553a3758f915a3da7d2f6d2fc38a42338e4262e44c0f83026240546aa30e4fcf18b5810436a03e9209d14e8ed228e353c60b32d92f647adcbb0f2e72d6808
diff --git a/games-sports/trigger/metadata.xml b/games-sports/trigger/metadata.xml
new file mode 100644
index 000000000000..e8df7dee9458
--- /dev/null
+++ b/games-sports/trigger/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">trigger-rally</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-sports/trigger/trigger-0.6.1.ebuild b/games-sports/trigger/trigger-0.6.1.ebuild
new file mode 100644
index 000000000000..a42faf645ab6
--- /dev/null
+++ b/games-sports/trigger/trigger-0.6.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_PN=${PN}-rally
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Free OpenGL rally car racing game"
+HOMEPAGE="http://www.positro.net/trigger/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer
+ media-libs/openal
+ media-libs/freealut
+ dev-games/physfs"
+DEPEND="${RDEPEND}
+ dev-util/ftjam"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ egamesconf --datadir="${GAMES_DATADIR}"/${PN}
+}
+
+src_compile() {
+ AR="${AR} cru" jam -dx -qa || die
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ newicon data/textures/life_helmet.png ${PN}.png
+ make_desktop_entry ${PN} Trigger
+ dodoc doc/*.txt
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "After running ${PN} for the first time, a config file is"
+ elog "available in ~/.trigger/trigger.config"
+}