summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-02 00:58:03 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-02 01:26:53 -0400
commit83c3e9277bbf53bc7eb714b7b100a0b9786a717f (patch)
tree0ba450c7b067d630bb86fa517c8baed750abbbde /games-puzzle
parentprofiles/package.mask: add bug reference to openstack removal (diff)
downloadgentoo-83c3e9277bbf53bc7eb714b7b100a0b9786a717f.tar.gz
gentoo-83c3e9277bbf53bc7eb714b7b100a0b9786a717f.tar.bz2
gentoo-83c3e9277bbf53bc7eb714b7b100a0b9786a717f.zip
games-puzzle/pathological: add python3_9, require <pygame-2
python3_9 works as expected but this game is unusable with pygame-2 regardless of the interpreter, restrict until fixed. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/pathological/pathological-1.1.3_p16-r2.ebuild (renamed from games-puzzle/pathological/pathological-1.1.3_p16-r1.ebuild)6
1 files changed, 4 insertions, 2 deletions
diff --git a/games-puzzle/pathological/pathological-1.1.3_p16-r1.ebuild b/games-puzzle/pathological/pathological-1.1.3_p16-r2.ebuild
index c41cdb26e8ec..9a41e9a28b0f 100644
--- a/games-puzzle/pathological/pathological-1.1.3_p16-r1.ebuild
+++ b/games-puzzle/pathological/pathological-1.1.3_p16-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{8,9} )
inherit desktop python-single-r1 toolchain-funcs
@@ -20,9 +20,11 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# Note: locks up at start with >=pygame-2 (debian uses pygame-1, fix needed)
RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
- >=dev-python/pygame-1.5.5[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygame-1.5.5[${PYTHON_USEDEP}]
+ <dev-python/pygame-2[${PYTHON_USEDEP}]
')
"
DEPEND="${RDEPEND}"