summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/xpired
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/xpired')
-rw-r--r--games-puzzle/xpired/Manifest1
-rw-r--r--games-puzzle/xpired/files/xpired-1.22-ldflags.patch26
-rw-r--r--games-puzzle/xpired/metadata.xml8
-rw-r--r--games-puzzle/xpired/xpired-1.22.ebuild41
4 files changed, 76 insertions, 0 deletions
diff --git a/games-puzzle/xpired/Manifest b/games-puzzle/xpired/Manifest
new file mode 100644
index 000000000000..47d23b32e538
--- /dev/null
+++ b/games-puzzle/xpired/Manifest
@@ -0,0 +1 @@
+DIST xpired-1.22-linux_source.tar.gz 478593 SHA256 7a2c0dd8bab0dc2b937684bbb3d213754921bf2d6bd891d9be00bf2db7bbb505 SHA512 08e506e6206be9346bde083a9cdd25a890c0100826a7fb2b515b60180cfd0b885712261db2e7a5d589078c0b74f2b9ad659b39d9378cb3dc92af111ab499ee10 WHIRLPOOL 166f0149290c7bcd3ae24d26152f502b157a84439c79fbcd4a34e425b857dc8965584e60c455de2b387427e3f89c841f5a52c7f1ae20ee02bc9d5c0e17d77e2a
diff --git a/games-puzzle/xpired/files/xpired-1.22-ldflags.patch b/games-puzzle/xpired/files/xpired-1.22-ldflags.patch
new file mode 100644
index 000000000000..f3a1e6839cf4
--- /dev/null
+++ b/games-puzzle/xpired/files/xpired-1.22-ldflags.patch
@@ -0,0 +1,26 @@
+diff -ru src.orig/Makefile src/Makefile
+--- src.orig/Makefile 2002-08-01 14:42:51.000000000 -0400
++++ src/Makefile 2010-10-13 19:31:21.944183145 -0400
+@@ -1,18 +1,17 @@
+ PREFIX=/usr/local
+ SHARE_PREFIX=$(PREFIX)/share/xpired
+-CFLAGS=`sdl-config --cflags` -DUNIX -DPREFIX=\"$(PREFIX)\" -DSHARE_PREFIX=\"$(SHARE_PREFIX)\"
+-LDFLAGS=`sdl-config --libs` -lSDL -lSDL_mixer -lSDL_image -lSDL_gfx
+-CC=gcc
++CFLAGS+=`sdl-config --cflags` -DUNIX -DPREFIX=\"$(PREFIX)\" -DSHARE_PREFIX=\"$(SHARE_PREFIX)\"
++LDLIBS=`sdl-config --libs` -lSDL -lSDL_mixer -lSDL_image -lSDL_gfx
+
+ BINARIES = xpired xpiredit
+
+ all: $(BINARIES)
+
+ xpired: xpired.o
+- $(CC) -o xpired xpired.o $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o xpired xpired.o $(LDLIBS)
+
+ xpiredit: xpiredit.o xpired_unix.h
+- $(CC) -o xpiredit xpiredit.o $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o xpiredit xpiredit.o $(LDLIBS)
+
+ .PHONY: clean
+
diff --git a/games-puzzle/xpired/metadata.xml b/games-puzzle/xpired/metadata.xml
new file mode 100644
index 000000000000..11c360ed350a
--- /dev/null
+++ b/games-puzzle/xpired/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">xpired</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/xpired/xpired-1.22.ebuild b/games-puzzle/xpired/xpired-1.22.ebuild
new file mode 100644
index 000000000000..1db2245a4663
--- /dev/null
+++ b/games-puzzle/xpired/xpired-1.22.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A Sokoban-styled puzzle game with lots more action"
+HOMEPAGE="http://xpired.sourceforge.net"
+SRC_URI="mirror://sourceforge/xpired/${P}-linux_source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="media-libs/sdl-gfx
+ media-libs/sdl-image[jpeg]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/src
+
+PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
+
+src_compile() {
+ emake \
+ PREFIX=/usr/games \
+ SHARE_PREFIX=/usr/share/games/xpired
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}/usr/games" \
+ SHARE_PREFIX="${D}/usr/share/games/${PN}" \
+ install
+ newicon img/icon.bmp ${PN}.bmp
+ make_desktop_entry xpired Xpired /usr/share/pixmaps/${PN}.bmp
+ make_desktop_entry xpiredit "Xpired Level Editor"
+ prepgamesdirs
+}