summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/sdl-jewels
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/sdl-jewels')
-rw-r--r--games-puzzle/sdl-jewels/Manifest1
-rw-r--r--games-puzzle/sdl-jewels/files/sdl-jewels-1.1.1-Makefile.patch17
-rw-r--r--games-puzzle/sdl-jewels/metadata.xml5
-rw-r--r--games-puzzle/sdl-jewels/sdl-jewels-1.1.1.ebuild43
4 files changed, 66 insertions, 0 deletions
diff --git a/games-puzzle/sdl-jewels/Manifest b/games-puzzle/sdl-jewels/Manifest
new file mode 100644
index 000000000000..7f434f2402ff
--- /dev/null
+++ b/games-puzzle/sdl-jewels/Manifest
@@ -0,0 +1 @@
+DIST SDL_jewels-1.1.1.tgz 195366 SHA256 c9a40b7e18fabb03e4065e656bc2c30f595103bf20dc74a10847c3f3aa138ee7 SHA512 720f1d89384bf267e8f5441efd70fcf94bfc89ddbd0ff90b1dafc6381e83e005281fcde256ee4cd0645f2832cf9c22aed487c105d7d9cf39711c5752e12763c4 WHIRLPOOL 8ce6f3409a50a2ff673e545f1333f7f12d6b37bd6020f22d004072d0266be3936e98e0212925457f5ede4adb7e0f2346bc5c8a00b3c8e74b3f4b61cb397f78f1
diff --git a/games-puzzle/sdl-jewels/files/sdl-jewels-1.1.1-Makefile.patch b/games-puzzle/sdl-jewels/files/sdl-jewels-1.1.1-Makefile.patch
new file mode 100644
index 000000000000..ba27fd5447bf
--- /dev/null
+++ b/games-puzzle/sdl-jewels/files/sdl-jewels-1.1.1-Makefile.patch
@@ -0,0 +1,17 @@
+--- SDL_jewels-1.1.1/Makefile.old 2010-11-13 00:46:47.196000082 +0000
++++ SDL_jewels-1.1.1/Makefile 2010-11-13 01:45:14.516000087 +0000
+@@ -1,11 +1,12 @@
+ EXE = gljewel
+
+-CFLAGS = -O2 -Wall $(shell sdl-config --cflags)
+-LDFLAGS = $(shell sdl-config --libs) -lGL -lm
++CFLAGS += -Wall $(shell sdl-config --cflags)
++LIBS = $(shell sdl-config --libs) -lGL -lm
+
+ OBJS = $(EXE).o matrix.o sound.o
+
+ $(EXE): $(OBJS)
++ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ $(EXE).o: $(EXE).c matrix.h misc.h
+
diff --git a/games-puzzle/sdl-jewels/metadata.xml b/games-puzzle/sdl-jewels/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/sdl-jewels/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/sdl-jewels/sdl-jewels-1.1.1.ebuild b/games-puzzle/sdl-jewels/sdl-jewels-1.1.1.ebuild
new file mode 100644
index 000000000000..395a8bb72f57
--- /dev/null
+++ b/games-puzzle/sdl-jewels/sdl-jewels-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Swap and match 3 or more jewels in a line in order to score points"
+HOMEPAGE="http://www.linuxmotors.com/gljewel/"
+SRC_URI="http://www.linuxmotors.com/gljewel/downloads/SDL_jewels-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="media-libs/libsdl[opengl,video]
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/SDL_jewels-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+
+ # fix the data dir locations as it looks to be intended to run from src dir
+ sed -i -e "s|\"data\"|\"${GAMES_DATADIR}/${PN}\"|" sound.c || die
+ sed -i -e "s|data/bigfont.ppm|${GAMES_DATADIR}/${PN}/bigfont.ppm|" gljewel.c || die
+ ecvs_clean
+}
+
+src_install() {
+ dogamesbin gljewel
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/*
+
+ dodoc ChangeLog README
+
+ make_desktop_entry gljewel SDL_jewels
+ prepgamesdirs
+}