summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2017-05-10 21:55:21 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-05-10 21:55:32 +0200
commitfccde5cf308d9d08016e70873ca8ca041c94b7e7 (patch)
treec2a1364be3270d4e75c4348b4252d794870c5e32 /games-fps/urbanterror/files
parentgames-fps/urbanterror-data: initial import, split out of games-fps/urbanterror (diff)
downloadgentoo-fccde5cf308d9d08016e70873ca8ca041c94b7e7.tar.gz
gentoo-fccde5cf308d9d08016e70873ca8ca041c94b7e7.tar.bz2
gentoo-fccde5cf308d9d08016e70873ca8ca041c94b7e7.zip
games-fps/urbanterror: Bump to v4.3.2_p20170426 (bug #596982)
EBuild changes: =============== - Ebuild no longer uses bundled libs (bug #457014) - Contains fixes for / no longer affected by CVE-2011-1412, CVE-2011-2764, CVE-2011-3012,CVE-2012-3345 due to updated/changed engine (bug #606702) - Fixed some format-security problems (bug #545966) Closes: https://github.com/gentoo/gentoo/pull/4172 Gentoo-Bug: https://bugs.gentoo.org/596982 Gentoo-Bug: https://bugs.gentoo.org/457014 Gentoo-Bug: https://bugs.gentoo.org/545966 Gentoo-Bug: https://bugs.gentoo.org/606702 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'games-fps/urbanterror/files')
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.3-respect_CFLAGS.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-fps/urbanterror/files/urbanterror-4.3-respect_CFLAGS.patch b/games-fps/urbanterror/files/urbanterror-4.3-respect_CFLAGS.patch
new file mode 100644
index 000000000000..5ce13342ab58
--- /dev/null
+++ b/games-fps/urbanterror/files/urbanterror-4.3-respect_CFLAGS.patch
@@ -0,0 +1,53 @@
+Author: holgersson <holgersson@posteo.de>
+Date: Fri Mar 31 12:13:00 2017 +0200
+
+Respect CFLAGS - inspired by hasufell’s patch
+
+--- a/Makefile 2017-03-31 11:08:58.419210817 +0200
++++ b/Makefile 2017-03-31 12:06:52.559412054 +0200
+@@ -290,34 +290,33 @@
+ CLIENT_EXTRA_FILES=
+
+ ifneq (,$(findstring "$(PLATFORM)", "linux" "gnu_kfreebsd" "kfreebsd-gnu" "gnu"))
+- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes \
+- -pipe -DUSE_ICON -DARCH_STRING=\\\"$(ARCH)\\\"
++ BASE_CFLAGS = -DUSE_ICON -DARCH_STRING=\\\"$(ARCH)\\\"
+ CLIENT_CFLAGS += $(SDL_CFLAGS)
+
+- OPTIMIZEVM = -O3
+- OPTIMIZE = $(OPTIMIZEVM) -ffast-math
++ OPTIMIZEVM =
++ OPTIMIZE = $(OPTIMIZEVM)
+
+ ifeq ($(ARCH),x86_64)
+- OPTIMIZEVM = -O3
+- OPTIMIZE = $(OPTIMIZEVM) -ffast-math
++ OPTIMIZEVM =
++ OPTIMIZE = $(OPTIMIZEVM)
+ HAVE_VM_COMPILED = true
+ else
+ ifeq ($(ARCH),x86)
+- OPTIMIZEVM = -O3 -march=i586
+- OPTIMIZE = $(OPTIMIZEVM) -ffast-math
++ OPTIMIZEVM =
++ OPTIMIZE = $(OPTIMIZEVM)
+ HAVE_VM_COMPILED=true
+ else
+ ifeq ($(ARCH),ppc)
+- BASE_CFLAGS += -maltivec
++ BASE_CFLAGS +=
+ HAVE_VM_COMPILED=true
+ endif
+ ifeq ($(ARCH),ppc64)
+- BASE_CFLAGS += -maltivec
++ BASE_CFLAGS +=
+ HAVE_VM_COMPILED=true
+ endif
+ ifeq ($(ARCH),sparc)
+- OPTIMIZE += -mtune=ultrasparc3 -mv8plus
+- OPTIMIZEVM += -mtune=ultrasparc3 -mv8plus
++ OPTIMIZE +=
++ OPTIMIZEVM +=
+ HAVE_VM_COMPILED=true
+ endif
+ ifeq ($(ARCH),armv7l)