summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-07-24 10:34:56 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-08-02 22:55:01 +0100
commitde8b8298a0223a78ac51188e9d619537d5132ce9 (patch)
treed444e73d30bab228615b0cf228b4f3f8467ab307 /games-engines
parentpackage.mask: Last rite app-backup/mkstage4 (diff)
downloadgentoo-de8b8298a0223a78ac51188e9d619537d5132ce9.tar.gz
gentoo-de8b8298a0223a78ac51188e9d619537d5132ce9.tar.bz2
gentoo-de8b8298a0223a78ac51188e9d619537d5132ce9.zip
games-engines/fheroes2: add 1.1.1
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/fheroes2/Manifest1
-rw-r--r--games-engines/fheroes2/fheroes2-1.1.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/games-engines/fheroes2/Manifest b/games-engines/fheroes2/Manifest
index 443a74152169..7c7ddaa0f123 100644
--- a/games-engines/fheroes2/Manifest
+++ b/games-engines/fheroes2/Manifest
@@ -1 +1,2 @@
DIST fheroes2-1.1.0.tar.gz 12165311 BLAKE2B 11702a2c98ad4aae331ee4ec5c45e25ffcfd9c63bba9078b60f620204c7a32addc36bf2959c98d1be2ed0c7f4b16ea8143329d6d9280f2f24b8c2657c4a37cc1 SHA512 a02a897074b4cc4b2b1f32854e162baa38c120e1211c28c12487cbff649171d60ef509aa55a838ac8239959c8d48bca1dff6629eaf2bba048623f5345f0b2ce3
+DIST fheroes2-1.1.1.tar.gz 12212585 BLAKE2B 0adc66e83c86c0b0535ad4dead0dc8157dbf69b683e2f1d0ef737bff6b3780bd9ed09bd99a4a168a6f8bd8fdf2672b8f2cfd06bf739b53222510673189572a28 SHA512 08aceb9755558516eb747f13b0c4e442786a9a818120e077de6d6921b6fb7e44c440b94447d36c7c735d3670656259b49eac6965656352590d58572756ed7990
diff --git a/games-engines/fheroes2/fheroes2-1.1.1.ebuild b/games-engines/fheroes2/fheroes2-1.1.1.ebuild
new file mode 100644
index 000000000000..c54e921e38d6
--- /dev/null
+++ b/games-engines/fheroes2/fheroes2-1.1.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake python-single-r1 xdg
+
+DESCRIPTION="Recreation of HoMM2 game engine"
+HOMEPAGE="https://ihhub.github.io/fheroes2/"
+SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ media-libs/libpng:=
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image
+ media-libs/sdl2-mixer
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ app-arch/libarchive
+ dev-lang/python
+ virtual/libintl
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
+)
+
+src_configure() {
+ # Not using dev-games/libsmacker because the game crashes with it
+ local mycmakeargs=(
+ -DENABLE_IMAGE=ON
+ -DENABLE_TOOLS=$(usex tools)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ emake -C files/lang
+}
+
+src_install() {
+ cmake_src_install
+
+ if use tools; then
+ for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
+ newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need original HoMM2 data files to play fheroes2."
+ elog "If you have an installer (.exe) from GOG, install:"
+ elog " games-strategy/homm2-gold-gog"
+ elog "If you have the original game installed somewhere already, run:"
+ elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
+ elog "Also you can automatically get a demo version for free by installing:"
+ elog " games-strategy/homm2-demo"
+}