summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-17 12:30:41 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-17 15:27:19 +0200
commite6decb2f6f86e8823232b37e4f090a66b95df697 (patch)
tree3551ddb1cb418fa7ec85877360452e1c494c89e8 /games-emulation
parentx11-terms/kitty: add 0.36.0 (diff)
downloadgentoo-e6decb2f6f86e8823232b37e4f090a66b95df697.tar.gz
gentoo-e6decb2f6f86e8823232b37e4f090a66b95df697.tar.bz2
gentoo-e6decb2f6f86e8823232b37e4f090a66b95df697.zip
games-emulation/melonds: add new enet dependency to live 9999
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild37
1 files changed, 23 insertions, 14 deletions
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index ff839958a635..e20ccdc8096e 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-MY_PN="melonDS"
-MY_P="${MY_PN}-${PV}"
+REAL_PN="melonDS"
+REAL_P="${REAL_PN}-${PV}"
inherit cmake flag-o-matic readme.gentoo-r1 toolchain-funcs xdg
@@ -15,18 +15,18 @@ HOMEPAGE="http://melonds.kuribo64.net
if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+ EGIT_REPO_URI="https://github.com/Arisotura/${REAL_PN}.git"
else
- SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz
- -> ${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/Arisotura/${REAL_PN}/archive/${PV}.tar.gz
+ -> ${REAL_P}.tar.gz"
+ S="${WORKDIR}/${REAL_P}"
KEYWORDS="~amd64"
fi
-IUSE="+jit +opengl wayland"
LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
SLOT="0"
+IUSE="+jit +opengl wayland"
RDEPEND="
app-arch/libarchive
@@ -36,12 +36,21 @@ RDEPEND="
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
media-libs/libsdl2[sound,video]
+ net-libs/enet:=
net-libs/libpcap
net-libs/libslirp
- wayland? ( dev-libs/wayland )
+ wayland? (
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ wayland? (
+ kde-frameworks/extra-cmake-modules:0
+ )
"
-DEPEND="${RDEPEND}"
-BDEPEND="wayland? ( kde-frameworks/extra-cmake-modules:0 )"
# used for JIT recompiler
QA_EXECSTACK="usr/bin/melonDS"
@@ -64,10 +73,10 @@ src_prepare() {
src_configure() {
local -a mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DENABLE_JIT=$(usex jit)
- -DENABLE_OGLRENDERER=$(usex opengl)
- -DENABLE_WAYLAND=$(usex wayland)
+ -DBUILD_SHARED_LIBS="OFF"
+ -DENABLE_JIT="$(usex jit)"
+ -DENABLE_OGLRENDERER="$(usex opengl)"
+ -DENABLE_WAYLAND="$(usex wayland)"
)
cmake_src_configure
}