summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-01 10:23:01 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-01 22:13:54 -0500
commit444137034cccd5fdd488a9f2dc2c8ad0e605b0d2 (patch)
treecf2ff56db8ca916b4639e07203f8afb02a324a63 /games-emulation/mgba
parentx11-terms/kitty-shell-integration: drop 0.26.4 (diff)
downloadgentoo-444137034cccd5fdd488a9f2dc2c8ad0e605b0d2.tar.gz
gentoo-444137034cccd5fdd488a9f2dc2c8ad0e605b0d2.tar.bz2
gentoo-444137034cccd5fdd488a9f2dc2c8ad0e605b0d2.zip
games-emulation/mgba: drop 0.9.3-r2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/mgba')
-rw-r--r--games-emulation/mgba/Manifest1
-rw-r--r--games-emulation/mgba/files/mgba-0.9.3-ffmpeg5.patch109
-rw-r--r--games-emulation/mgba/mgba-0.9.3-r2.ebuild92
3 files changed, 0 insertions, 202 deletions
diff --git a/games-emulation/mgba/Manifest b/games-emulation/mgba/Manifest
index b7b04e1c2f88..07ecb0f2a4b1 100644
--- a/games-emulation/mgba/Manifest
+++ b/games-emulation/mgba/Manifest
@@ -1,2 +1 @@
DIST mgba-0.10.0.tar.gz 14302653 BLAKE2B 0ebfa8a3de5db61452f070116fcf2d6312ce96f5d08b1b1e70ba8f7e50235fecff2a0f6a5a32860b7e95e55a6ab5bbf2227d483bad7eb25d6c7e471424bcf0dd SHA512 05939f94bc00906d999b955091e8e8059cc13a5b822048f6e002062c2e74069337d947d2cde2f8c1be96e3353a361743d752811c214fa9da31ed6a4893b4d7e8
-DIST mgba-0.9.3.tar.gz 12763090 BLAKE2B 7d9ff6fc7bdff5d734540b74893a888d400b4bb6e1ce5b3b2a856239db8798ac76b8535dc770330d0451e2568a6d402558eeef27d643c0d5d3454441f45cf09b SHA512 da65b3c7ec32d732163f129c4fd38949ae2da2980beb3257bf6def5e35534a27b6d30309bb3c9a8d651642f99e1a45db7a8577c8dbf5472153d4551167471b3a
diff --git a/games-emulation/mgba/files/mgba-0.9.3-ffmpeg5.patch b/games-emulation/mgba/files/mgba-0.9.3-ffmpeg5.patch
deleted file mode 100644
index 6b8d55c377ea..000000000000
--- a/games-emulation/mgba/files/mgba-0.9.3-ffmpeg5.patch
+++ /dev/null
@@ -1,109 +0,0 @@
-https://bugs.gentoo.org/834374
-
-https://github.com/mgba-emu/mgba/commit/cdc753516798882a805db1d2042dbce8313382bf
-From: Ryan Tandy <ryan@nardis.ca>
-Date: Thu, 3 Feb 2022 19:02:52 -0800
-Subject: [PATCH] FFmpeg: Support FFmpeg 5.0
---- a/src/feature/ffmpeg/ffmpeg-decoder.c
-+++ b/src/feature/ffmpeg/ffmpeg-decoder.c
-@@ -5,6 +5,7 @@
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
- #include "ffmpeg-decoder.h"
-
-+#include <libavcodec/avcodec.h>
- #include <libswscale/swscale.h>
-
- void FFmpegDecoderInit(struct FFmpegDecoder* decoder) {
-@@ -38,7 +39,7 @@ bool FFmpegDecoderOpen(struct FFmpegDecoder* decoder, const char* infile) {
- #else
- enum AVMediaType type = decoder->context->streams[i]->codec->codec_type;
- #endif
-- struct AVCodec* codec;
-+ const struct AVCodec* codec;
- struct AVCodecContext* context = NULL;
- if (type == AVMEDIA_TYPE_VIDEO && decoder->videoStream < 0) {
- decoder->video = avcodec_alloc_context3(NULL);
---- a/src/feature/ffmpeg/ffmpeg-encoder.c
-+++ b/src/feature/ffmpeg/ffmpeg-encoder.c
-@@ -12,6 +12,9 @@
-
- #include <libavcodec/version.h>
- #include <libavcodec/avcodec.h>
-+#if LIBAVCODEC_VERSION_MAJOR >= 58
-+#include <libavcodec/bsf.h>
-+#endif
-
- #include <libavfilter/buffersink.h>
- #include <libavfilter/buffersrc.h>
-@@ -121,7 +124,7 @@ bool FFmpegEncoderSetAudio(struct FFmpegEncoder* encoder, const char* acodec, un
- return true;
- }
-
-- AVCodec* codec = avcodec_find_encoder_by_name(acodec);
-+ const AVCodec* codec = avcodec_find_encoder_by_name(acodec);
- if (!codec) {
- return false;
- }
-@@ -193,7 +196,7 @@ bool FFmpegEncoderSetVideo(struct FFmpegEncoder* encoder, const char* vcodec, in
- return true;
- }
-
-- AVCodec* codec = avcodec_find_encoder_by_name(vcodec);
-+ const AVCodec* codec = avcodec_find_encoder_by_name(vcodec);
- if (!codec) {
- return false;
- }
-@@ -213,7 +216,7 @@ bool FFmpegEncoderSetVideo(struct FFmpegEncoder* encoder, const char* vcodec, in
- if (encoder->pixFormat == AV_PIX_FMT_NONE) {
- return false;
- }
-- if (vbr < 0 && !av_opt_find(&codec->priv_class, "crf", NULL, 0, 0)) {
-+ if (vbr < 0 && !av_opt_find((void*) &codec->priv_class, "crf", NULL, 0, 0)) {
- return false;
- }
- encoder->videoCodec = vcodec;
-@@ -223,7 +226,7 @@ bool FFmpegEncoderSetVideo(struct FFmpegEncoder* encoder, const char* vcodec, in
- }
-
- bool FFmpegEncoderSetContainer(struct FFmpegEncoder* encoder, const char* container) {
-- AVOutputFormat* oformat = av_guess_format(container, 0, 0);
-+ const AVOutputFormat* oformat = av_guess_format(container, 0, 0);
- if (!oformat) {
- return false;
- }
-@@ -241,9 +244,9 @@ void FFmpegEncoderSetLooping(struct FFmpegEncoder* encoder, bool loop) {
- }
-
- bool FFmpegEncoderVerifyContainer(struct FFmpegEncoder* encoder) {
-- AVOutputFormat* oformat = av_guess_format(encoder->containerFormat, 0, 0);
-- AVCodec* acodec = avcodec_find_encoder_by_name(encoder->audioCodec);
-- AVCodec* vcodec = avcodec_find_encoder_by_name(encoder->videoCodec);
-+ const AVOutputFormat* oformat = av_guess_format(encoder->containerFormat, 0, 0);
-+ const AVCodec* acodec = avcodec_find_encoder_by_name(encoder->audioCodec);
-+ const AVCodec* vcodec = avcodec_find_encoder_by_name(encoder->videoCodec);
- if ((encoder->audioCodec && !acodec) || (encoder->videoCodec && !vcodec) || !oformat || (!acodec && !vcodec)) {
- return false;
- }
-@@ -257,8 +260,8 @@ bool FFmpegEncoderVerifyContainer(struct FFmpegEncoder* encoder) {
- }
-
- bool FFmpegEncoderOpen(struct FFmpegEncoder* encoder, const char* outfile) {
-- AVCodec* acodec = avcodec_find_encoder_by_name(encoder->audioCodec);
-- AVCodec* vcodec = avcodec_find_encoder_by_name(encoder->videoCodec);
-+ const AVCodec* acodec = avcodec_find_encoder_by_name(encoder->audioCodec);
-+ const AVCodec* vcodec = avcodec_find_encoder_by_name(encoder->videoCodec);
- if ((encoder->audioCodec && !acodec) || (encoder->videoCodec && !vcodec) || !FFmpegEncoderVerifyContainer(encoder)) {
- return false;
- }
-@@ -272,9 +275,9 @@ bool FFmpegEncoderOpen(struct FFmpegEncoder* encoder, const char* outfile) {
- encoder->currentVideoFrame = 0;
- encoder->skipResidue = 0;
-
-- AVOutputFormat* oformat = av_guess_format(encoder->containerFormat, 0, 0);
-+ const AVOutputFormat* oformat = av_guess_format(encoder->containerFormat, 0, 0);
- #ifndef USE_LIBAV
-- avformat_alloc_output_context2(&encoder->context, oformat, 0, outfile);
-+ avformat_alloc_output_context2(&encoder->context, (AVOutputFormat*) oformat, 0, outfile);
- #else
- encoder->context = avformat_alloc_context();
- strncpy(encoder->context->filename, outfile, sizeof(encoder->context->filename) - 1);
diff --git a/games-emulation/mgba/mgba-0.9.3-r2.ebuild b/games-emulation/mgba/mgba-0.9.3-r2.ebuild
deleted file mode 100644
index 82caf353a7fa..000000000000
--- a/games-emulation/mgba/mgba-0.9.3-r2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mgba-emu/mgba.git"
-else
- SRC_URI="https://github.com/mgba-emu/mgba/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-fi
-
-DESCRIPTION="Game Boy Advance Emulator"
-HOMEPAGE="https://mgba.io/"
-
-LICENSE="MPL-2.0 BSD LGPL-2.1+ public-domain discord? ( MIT )"
-SLOT="0/9"
-IUSE="debug discord elf ffmpeg gles2 gles3 gui libretro opengl +sdl sqlite test"
-# gles2/gles3 opengl require can be lifted in next version (bug #835039)
-REQUIRED_USE="
- || ( gui sdl )
- gles2? ( opengl )
- gles3? ( opengl )
- gui? ( || ( gles2 opengl ) )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- media-libs/libpng:=
- sys-libs/zlib:=[minizip]
- debug? ( dev-libs/libedit )
- elf? ( dev-libs/elfutils )
- ffmpeg? ( media-video/ffmpeg:= )
- gles2? ( media-libs/libglvnd )
- gles3? ( media-libs/libglvnd )
- opengl? ( media-libs/libglvnd )
- gui? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
- )
- sdl? ( media-libs/libsdl2[sound,joystick,opengl?,video] )
- sqlite? ( dev-db/sqlite:3 )"
-DEPEND="
- ${RDEPEND}
- test? ( dev-util/cmocka )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-ffmpeg5.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CINEMA=$(usex test)
- -DBUILD_GL=$(usex opengl)
- -DBUILD_GLES2=$(usex gles2)
- -DBUILD_GLES3=$(usex gles3)
- -DBUILD_LIBRETRO=$(usex libretro)
- -DBUILD_QT=$(usex gui)
- -DBUILD_SDL=$(usex sdl)
- -DBUILD_SUITE=$(usex test)
- -DMARKDOWN=OFF #752048
- -DUSE_DEBUGGERS=$(usex debug)
- -DUSE_DISCORD_RPC=$(usex discord)
- -DUSE_EDITLINE=$(usex debug)
- -DUSE_ELF=$(usex elf)
- -DUSE_EPOXY=OFF
- -DUSE_FFMPEG=$(usex ffmpeg)
- -DUSE_GDB_STUB=$(usex debug)
- -DUSE_LIBZIP=OFF
- -DUSE_LZMA=ON
- -DUSE_MINIZIP=ON
- -DUSE_PNG=ON
- -DUSE_SQLITE3=$(usex sqlite)
- -DUSE_ZLIB=ON
- $(usev libretro -DLIBRETRO_LIBDIR="${EPREFIX}"/usr/$(get_libdir)/libretro)
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- use !test || rm "${ED}"/usr/bin/mgba-cinema || die
-
- rm -r "${ED}"/usr/share/doc/${PF}/{LICENSE,licenses} || die
-}