summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-24 16:53:14 -0400
committerSam James <sam@gentoo.org>2021-05-09 04:42:08 +0000
commit552bcb9ad29cc7b67e91e48172bb0f492198628d (patch)
treeaffb70e6e7240d8896e7b1768404c8b5bc639da0 /games-emulation/fceux
parentgames-emulation/fceux: add github remote-id (diff)
downloadgentoo-552bcb9ad29cc7b67e91e48172bb0f492198628d.tar.gz
gentoo-552bcb9ad29cc7b67e91e48172bb0f492198628d.tar.bz2
gentoo-552bcb9ad29cc7b67e91e48172bb0f492198628d.zip
games-emulation/fceux: add 2.3.0
Notable ebuild changes: - migrated to cmake (drops python/scons) - libsdl2 over libsdl - build with QT5 (upstream removed support to build without gui) - removed all IUSE: > logo: create_avi / logo support missing from new build system > lua: always required, otherwise uses internal lua5.1 > opengl: fails if missing > gtk: while still usable, upstream discourages it, lacks some features, can't be built at same time, and next upcoming version removed support entirely (adds QT6 support instead) Closes: https://bugs.gentoo.org/782640 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20532 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation/fceux')
-rw-r--r--games-emulation/fceux/Manifest1
-rw-r--r--games-emulation/fceux/fceux-2.3.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/games-emulation/fceux/Manifest b/games-emulation/fceux/Manifest
index 134f52e94343..f816c7e3e354 100644
--- a/games-emulation/fceux/Manifest
+++ b/games-emulation/fceux/Manifest
@@ -1 +1,2 @@
DIST fceux-2.2.3.src.tar.gz 9292792 BLAKE2B 44412934a50f2cab581cb194932a079071e8c7c1cb4cb4d173e9d7cf4898806fe1b0948d6e86fd70d1265eb596c47f77f751e3a113f03aba9b95e1f5def9c2a8 SHA512 6deb83e9e773694f4040f5f325b0b5b4f45d58bb3481db67b4659c940d90c4c87e3ffeac712b72ddb3f5d089cd9fc7b55b497db61f708c23a7c43c17eda55c7b
+DIST fceux-2.3.0.src.tar.gz 20779030 BLAKE2B 0d9a0e1f326bdcde4e360a03755c9d807a59e3f3826017e2923527f3ec214bec4c9737f98a8abc4e4971098d127ce8e95eb4142fa8d0bd71109190e6d2c93861 SHA512 46b53f0c4c790ae4f7d5e800adf81cce3c7ccf4b06f972d46e29c0170485e291516709a8c28b26c762d535453e280a6c6de935869c7674bb135c3dca2e266407
diff --git a/games-emulation/fceux/fceux-2.3.0.ebuild b/games-emulation/fceux/fceux-2.3.0.ebuild
new file mode 100644
index 000000000000..94313a079d6c
--- /dev/null
+++ b/games-emulation/fceux/fceux-2.3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-1 )
+
+inherit cmake lua-single xdg
+
+DESCRIPTION="Portable Famicom/NES emulator, an evolution of the original FCE Ultra"
+HOMEPAGE="https://fceux.com/"
+SRC_URI="mirror://sourceforge/fceultra/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ media-libs/libglvnd
+ media-libs/libsdl2[joystick,sound,threads,video]
+ sys-libs/zlib:=[minizip]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.2-warnings.patch
+)
+DOCS=( README TODO-SDL changelog.txt documentation/. readme.md )
+
+src_prepare() {
+ cmake_src_prepare
+
+ # remove hardcoded paths and deprecated options from .desktop
+ sed -e '/^Exec=/s:=.*/:=:' \
+ -e '/^Icon=/s:=.*:=fceux1:' \
+ -e '/^OnlyShowIn=/d' \
+ -i fceux.desktop || die
+
+ # avoid QA notice if no git, returns empty strings either way
+ sed -i '/^GIT_/s:=.*:=:' scripts/genGitHdr.sh || die
+}
+
+src_install() {
+ cmake_src_install
+
+ # remove unused/duplicate files
+ rm "${ED}"/usr/share/fceux/{lua5{1,.1}.dll,{fceux,taseditor}.chm} \
+ "${ED}"/usr/share/doc/${PF}/fceux{,-net-server}.6 \
+ "${ED}"/usr/share/man/man6/fceux-net-server.6 || die
+}