summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 01:24:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:37:02 -0400
commitc2dc92f4ccdd4d811106d8e9b5db0baea78fe354 (patch)
tree6698bd6df36c7f9efec35973a808eb341bb033ad /games-board
parentgames-board/xgammon: force gcc -E for imake's generation (diff)
downloadgentoo-c2dc92f4ccdd4d811106d8e9b5db0baea78fe354.tar.gz
gentoo-c2dc92f4ccdd4d811106d8e9b5db0baea78fe354.tar.bz2
gentoo-c2dc92f4ccdd4d811106d8e9b5db0baea78fe354.zip
games-board/xmille: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems (this one notably has a Makefile.noIm which haven't tried). wrt #739154 package is still severely broken, moreso with >=clang16. Bug: https://bugs.gentoo.org/739154 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xmille/xmille-2.0-r4.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/games-board/xmille/xmille-2.0-r4.ebuild b/games-board/xmille/xmille-2.0-r4.ebuild
index 88cc7b1c9dff..4da9cc9cdc46 100644
--- a/games-board/xmille/xmille-2.0-r4.ebuild
+++ b/games-board/xmille/xmille-2.0-r4.ebuild
@@ -18,22 +18,22 @@ KEYWORDS="~amd64 ~x86"
BDEPEND="
app-text/rman
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1
"
RDEPEND="x11-libs/libXext"
DEPEND="${RDEPEND}"
-src_prepare() {
- default
- eapply "${WORKDIR}"/${PN}_${PV}-${DEB_PATCH_VER}.diff
-}
+PATCHES=(
+ "${WORKDIR}"/${PN}_${PV}-${DEB_PATCH_VER}.diff
+)
src_configure() {
# bug #858620
filter-lto
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {