summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-10 22:31:05 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-10 23:08:48 -0400
commit4046aacb83395ab4e0f227c85d72736cb9fedd77 (patch)
treef6e697a2d63d9476b2a02e54bdd92f39b520db3c /games-board
parentapp-emacs/posframe: bump to 1.1.8 (diff)
downloadgentoo-4046aacb83395ab4e0f227c85d72736cb9fedd77.tar.gz
gentoo-4046aacb83395ab4e0f227c85d72736cb9fedd77.tar.bz2
gentoo-4046aacb83395ab4e0f227c85d72736cb9fedd77.zip
games-board/xskat: adjust CPPFLAGS, move xorg-proto to DEPEND
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xskat/xskat-4.0-r2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-board/xskat/xskat-4.0-r2.ebuild b/games-board/xskat/xskat-4.0-r2.ebuild
index da925919f0cc..e32197c981c3 100644
--- a/games-board/xskat/xskat-4.0-r2.ebuild
+++ b/games-board/xskat/xskat-4.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,13 +15,14 @@ LICENSE="freedist"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-DEPEND="x11-libs/libX11"
+COMMON_DEPEND="x11-libs/libX11"
RDEPEND="
- ${DEPEND}
+ ${COMMON_DEPEND}
media-fonts/font-misc-misc"
-BDEPEND="
- virtual/pkgconfig
+DEPEND="
+ ${COMMON_DEPEND}
x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
src_configure() { :; }
@@ -29,7 +30,8 @@ src_compile() {
tc-export CC
local emakeargs=(
- CFLAGS="${CFLAGS} ${CPPFLAGS}"
+ CFLAGS="${CFLAGS} ${CPPFLAGS} $($(tc-getPKG_CONFIG) --cflags x11 || die)"
+ CPPFLAGS= # force everywhere above, but avoid implicit duplication
LDFLAGS="${LDFLAGS} $($(tc-getPKG_CONFIG) --libs x11 || die)"
)