summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-10-20 00:09:17 +0300
committerMart Raudsepp <leio@gentoo.org>2019-10-20 20:38:02 +0300
commitb5c435f3845c06be0a475f38c12b2b25c7b50e75 (patch)
tree23917071cf638972ea8385b2a3d08987ae8197cc /games-board/gnome-mines/gnome-mines-3.34.0.ebuild
parentmedia-sound/pulseaudio: remove old (diff)
downloadgentoo-b5c435f3845c06be0a475f38c12b2b25c7b50e75.tar.gz
gentoo-b5c435f3845c06be0a475f38c12b2b25c7b50e75.tar.bz2
gentoo-b5c435f3845c06be0a475f38c12b2b25c7b50e75.zip
games-board/gnome-mines: bump to 3.34.0
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'games-board/gnome-mines/gnome-mines-3.34.0.ebuild')
-rw-r--r--games-board/gnome-mines/gnome-mines-3.34.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-board/gnome-mines/gnome-mines-3.34.0.ebuild b/games-board/gnome-mines/gnome-mines-3.34.0.ebuild
new file mode 100644
index 000000000000..ab9be1d1c234
--- /dev/null
+++ b/games-board/gnome-mines/gnome-mines-3.34.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Clear hidden mines from a minefield"
+HOMEPAGE="https://wiki.gnome.org/Apps/Mines"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libgee:0.8
+ >=x11-libs/gtk+-3.12:3
+ dev-libs/libgnome-games-support:1=
+ >=gnome-base/librsvg-2.32.0:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gnome-base/librsvg:2[vala]
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}