summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-08-11 09:16:24 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-08-11 14:44:06 -0400
commit3b04cd8bbd78038085cf5d27a86d9e673513bb51 (patch)
tree12f85ef78d31f85cea8b4206c626bb746a1ac7f6 /games-arcade
parentapp-eselect/eselect-wine: update maintainers (diff)
downloadgentoo-3b04cd8bbd78038085cf5d27a86d9e673513bb51.tar.gz
gentoo-3b04cd8bbd78038085cf5d27a86d9e673513bb51.tar.bz2
gentoo-3b04cd8bbd78038085cf5d27a86d9e673513bb51.zip
games-arcade/balloonchase: EAPI6->8, misc changes
* use No_homepage/mirror (links dead with no replacement known) * make patch a little bit smaller and embed $(CXX) + $(PKG_CONFIG) * add missing EPREFIX * replace .bmp icon, neither right format nor size to be valid for XDG and no guarantees it can be displayed by everything Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/balloonchase/Manifest1
-rw-r--r--games-arcade/balloonchase/balloonchase-0.9.6-r1.ebuild34
-rw-r--r--games-arcade/balloonchase/balloonchase-0.9.6-r2.ebuild44
-rw-r--r--games-arcade/balloonchase/files/balloonchase-0.9.6-gentoo.patch (renamed from games-arcade/balloonchase/files/0.9.6-gentoo.patch)51
4 files changed, 56 insertions, 74 deletions
diff --git a/games-arcade/balloonchase/Manifest b/games-arcade/balloonchase/Manifest
index 9e11cb51d3df..86eaba1aa8fc 100644
--- a/games-arcade/balloonchase/Manifest
+++ b/games-arcade/balloonchase/Manifest
@@ -1 +1,2 @@
DIST balloonchase-0.9.6.tar.bz2 523085 BLAKE2B 50e453327d51da3fe40f52850cb2fbb7a10e897f59bac5d6f4a676d3211d3dcdae00359304ad119252ebf98e9f46482ad801078762f16ddc609bc94b68c3fc18 SHA512 ab5617713c96187564926fd5ecbdbf5186f78c23cfb43b26b28b9d18e71330efd77700cf7cd02e04be7fd8e33f2d30bf59f64954135ac82802d1d839dc2e7767
+DIST balloonchase.png 1744 BLAKE2B d78e636c0cb2ef521967035ce96fbee0e7b2659cb5127ba32cd3437394a709941fd915dfc0f376d47c2ad5ca81f6392f5942c2737cb2524ec3a041dc5b8c6c26 SHA512 bfd32d65b5cb290df90881cb7a953f1cac38f4e91151c672e4320b9b41f7bff46ef97d6c123aa7267b241710dccf4ade409ff129c945af1ee06d33fdf490f169
diff --git a/games-arcade/balloonchase/balloonchase-0.9.6-r1.ebuild b/games-arcade/balloonchase/balloonchase-0.9.6-r1.ebuild
deleted file mode 100644
index 36976cc63a40..000000000000
--- a/games-arcade/balloonchase/balloonchase-0.9.6-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit desktop toolchain-funcs
-
-DESCRIPTION="Fly a hot air balloon and try to blow the other player out of the screen"
-HOMEPAGE="http://makegho.mbnet.fi/c/bchase/"
-SRC_URI="http://makegho.mbnet.fi/c/bchase/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl[video]"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- eapply "${FILESDIR}"/${PV}-gentoo.patch
- sed -i "s:g++:$(tc-getCXX):" Makefile || die
- sed -i \
- -e "s:GENTOODIR:/usr/share/${PN}:" src/main.c || die
-}
-
-src_install() {
- dobin ${PN}
- insinto /usr/share/${PN}
- doins -r images
- newicon images/kp2b.bmp ${PN}.bmp
- make_desktop_entry ${PN} "Balloon Chase" /usr/share/pixmaps/${PN}.bmp
- einstalldocs
-}
diff --git a/games-arcade/balloonchase/balloonchase-0.9.6-r2.ebuild b/games-arcade/balloonchase/balloonchase-0.9.6-r2.ebuild
new file mode 100644
index 000000000000..aa65b89196ec
--- /dev/null
+++ b/games-arcade/balloonchase/balloonchase-0.9.6-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Fly a hot air balloon and try to blow the other player out of the screen"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="
+ mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-libs/libsdl[video]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "s|GENTOODIR|${EPREFIX}/usr/share/${PN}|" src/main.c || die
+
+ tc-export CXX PKG_CONFIG
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/${PN}
+ doins -r images
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} "Balloon Chase"
+
+ einstalldocs
+}
diff --git a/games-arcade/balloonchase/files/0.9.6-gentoo.patch b/games-arcade/balloonchase/files/balloonchase-0.9.6-gentoo.patch
index ff232693422b..c847f0677660 100644
--- a/games-arcade/balloonchase/files/0.9.6-gentoo.patch
+++ b/games-arcade/balloonchase/files/balloonchase-0.9.6-gentoo.patch
@@ -1,26 +1,18 @@
--- a/Makefile
+++ b/Makefile
-@@ -1,4 +1,3 @@
+@@ -1,2 +1 @@
-LDFLAGS= -lSDL -lpthread -s
CFLAGS= -Wall # -DDEBUG
- PKG_BCDIR=balloonchase-`cat src/ver`
- PKG_BCVER=`cat src/ver`
-@@ -9,8 +8,8 @@
- clean:
- rm balloonchase src/*.o
+@@ -11,4 +10,4 @@
main: src/main.c
- g++ -c -o src/main.o `sdl-config --cflags` src/main.c
- g++ -o balloonchase src/main.o `sdl-config --libs`
-+ g++ $(CXXFLAGS) -c -o src/main.o `sdl-config --cflags` src/main.c
-+ g++ $(LDFLAGS) -o balloonchase src/main.o `sdl-config --libs`
++ $(CXX) $(CXXFLAGS) -c -o src/main.o `$(PKG_CONFIG) --cflags sdl` src/main.c
++ $(CXX) $(LDFLAGS) -o balloonchase src/main.o `$(PKG_CONFIG) --libs sdl`
pkg:
- @echo $(PKG_BCVERSION) >VERSION
- rm balloonchase src/*.o
--- a/src/main.c
+++ b/src/main.c
-@@ -333,47 +333,47 @@
-
- int InitImages()
+@@ -335,35 +335,35 @@
{
- back = SDL_LoadBMP("images/back.bmp");
+ back = SDL_LoadBMP("GENTOODIR/images/back.bmp");
@@ -71,8 +63,7 @@
- font2 = SDL_LoadBMP("images/font.bmp");
+ font2 = SDL_LoadBMP("GENTOODIR/images/font.bmp");
font = SDL_CreateRGBSurface(SDL_SWSURFACE, 1288, 100, 32, 0xFF000000, 0x00FF0000, 0x0000FF00, 0x000000FF);
- SDL_SetColorKey(font, SDL_SRCCOLORKEY, SDL_MapRGB(font->format, 0x00, 0x00, 0x00));
- DrawIMG (font, font2, 0, 0);
+@@ -372,6 +372,6 @@
- blobtrox = SDL_LoadBMP("images/blobtrox.bmp");
+ blobtrox = SDL_LoadBMP("GENTOODIR/images/blobtrox.bmp");
@@ -81,27 +72,17 @@
- balloonchase = SDL_LoadBMP("images/balloonchase.bmp");
+ balloonchase = SDL_LoadBMP("GENTOODIR/images/balloonchase.bmp");
- TMP = SDL_CreateRGBSurface(SDL_SWSURFACE, 259, 200, 32, 0xFF000000, 0x00FF0000, 0x0000FF00, 0x000000FF);
- blursurface = SDL_CreateRGBSurface(SDL_SWSURFACE, 640, 480, 32, 0x00000000, 0x00000000, 0x00000000, 0x00000000);
-@@ -578,7 +578,7 @@
-
- void createdat(int winsneed, int option_wave_effect)
+@@ -580,3 +580,3 @@
{
- FILE *OPTFILE=fopen ("balloonchase.dat", "w+");
+ FILE *OPTFILE=fopen (".balloonchaserc", "w+");
char datmsg[60];
- sprintf (datmsg, "Balloon Chase settings file -- Do not edit manually!");
- char tmp2;
-@@ -588,52 +588,32 @@
- }
- fputc (winsneed, OPTFILE);
+@@ -590,3 +590,3 @@
fputc (option_wave_effect+2, OPTFILE);
- fprintf (stderr, "Saved configuration to balloonchase.dat\n");
+ fprintf (stderr, "Saved configuration to .balloonchaserc\n");
fclose (OPTFILE);
- }
-
- void checkfiles()
+@@ -596,42 +596,22 @@
{
- char found=0;
- #ifdef WIN32
@@ -161,23 +142,13 @@
+ createdat(2, 1);
+ }
}
-
- Uint32 rgb(Uint8 r, Uint8 g, Uint8 b)
-@@ -1257,7 +1237,7 @@
- SDL_WM_SetCaption ("Balloon Chase", 0);
- checkfiles();
+@@ -1259,3 +1239,3 @@
- FILE *OPTFILE=fopen ("balloonchase.dat", "r");
+ FILE *OPTFILE=fopen (".balloonchaserc", "r");
char datmsg[60];
- char varmistus[60];
-
-@@ -1275,7 +1255,7 @@
- {
- winsneeded=fgetc(OPTFILE);
+@@ -1277,3 +1257,3 @@
option_wave_effect=fgetc(OPTFILE)-2;
- fprintf (stderr, "Successfully loaded balloonchase.dat\n");
+ fprintf (stderr, "Successfully loaded .balloonchaserc\n");
}
- else
- {