summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/insaneodyssey/insaneodyssey-000311.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/insaneodyssey/insaneodyssey-000311.ebuild')
-rw-r--r--games-arcade/insaneodyssey/insaneodyssey-000311.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild b/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild
new file mode 100644
index 000000000000..277d66455c02
--- /dev/null
+++ b/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Help West Muldune escape from a futuristic mental hospital"
+HOMEPAGE="http://members.fortunecity.com/rivalentertainment/iox.html"
+# Upstream has download issues.
+#SRC_URI="http://members.fortunecity.com/rivalentertainment/io${PV}.tar.gz"
+SRC_URI="mirror://gentoo/io${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer
+ media-libs/sdl-image"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ cd ${PN}
+
+ # Modify data load code and paths to game data
+ sed -e "s:/usr/share/games:${GAMES_DATADIR}:" \
+ "${FILESDIR}"/${P}-datafiles.patch > "${T}"/datafiles.patch \
+ || die
+ epatch "${T}"/datafiles.patch
+ sed -i \
+ -e "/lvl/s:^:${GAMES_DATADIR}/${PN}/:" \
+ -e "s:night:${GAMES_DATADIR}/${PN}/night:" \
+ levels.dat || die
+ sed -i \
+ -e "s:tiles.dat:${GAMES_DATADIR}/${PN}/tiles.dat:" \
+ -e "s:sprites.dat:${GAMES_DATADIR}/${PN}/sprites.dat:" \
+ -e "s:levels.dat:${GAMES_DATADIR}/${PN}/levels.dat:" \
+ -e "s:IO_T:${GAMES_DATADIR}/${PN}/IO_T:" \
+ -e "s:tiles.att:${GAMES_DATADIR}/${PN}/tiles.att:" \
+ -e "s:shot:${GAMES_DATADIR}/${PN}/shot:" \
+ io.cpp || die
+ sed -i \
+ -e 's:\[32:[100:' \
+ io.h || die
+}
+
+src_install() {
+ cd ${PN}
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *bmp *png *dat *att *lvl *wav *mod *IT
+ newicon west00r.png ${PN}.png
+ make_desktop_entry ${PN} "Insane Odyssey"
+ prepgamesdirs
+}