summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/funnyboat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/funnyboat')
-rw-r--r--games-arcade/funnyboat/Manifest1
-rw-r--r--games-arcade/funnyboat/funnyboat-1.5-r1.ebuild56
-rw-r--r--games-arcade/funnyboat/metadata.xml8
3 files changed, 65 insertions, 0 deletions
diff --git a/games-arcade/funnyboat/Manifest b/games-arcade/funnyboat/Manifest
new file mode 100644
index 000000000000..9626106dc1bd
--- /dev/null
+++ b/games-arcade/funnyboat/Manifest
@@ -0,0 +1 @@
+DIST funnyboat-1.5-src.zip 3839990 SHA256 de001d17f0e380df89bf5000392db75b385851a3cd200b3b87a8a9b66502f016 SHA512 7d38070e73825602d6f0a82e810fe8937fe919ce12f6e802ee25147ca1a2333c2b90821d92e20b8e071070505099bf9ec562e8c7b8cd8d241c3021b840e707cc WHIRLPOOL ad350d8d16276a830e9ac1d42a3ced1572c79260bf247d26235e0f67c2ff4324e8b332eb4f5d12e3e87a56c8e19bb90ef5fd49bee0dbb46efd96bddac55f6f31
diff --git a/games-arcade/funnyboat/funnyboat-1.5-r1.ebuild b/games-arcade/funnyboat/funnyboat-1.5-r1.ebuild
new file mode 100644
index 000000000000..3dd158532c60
--- /dev/null
+++ b/games-arcade/funnyboat/funnyboat-1.5-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils gnome2-utils python-single-r1 games
+
+DESCRIPTION="A side scrolling shooter game starring a steamboat on the sea"
+HOMEPAGE="http://funnyboat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/pygame-1.6.2[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data *.py
+ python_optimize "${ED%/}/${GAMES_DATADIR}"/${PN}
+
+ dodoc *.txt
+ games_make_wrapper ${PN} "${EPYTHON} main.py" "${GAMES_DATADIR}"/${PN}
+ newicon -s 32 data/kuvake.png ${PN}.png
+ make_desktop_entry ${PN} "Trip on the Funny Boat"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-arcade/funnyboat/metadata.xml b/games-arcade/funnyboat/metadata.xml
new file mode 100644
index 000000000000..f665da6a8949
--- /dev/null
+++ b/games-arcade/funnyboat/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">funnyboat</remote-id>
+ </upstream>
+</pkgmetadata>