summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-06 20:00:26 +0200
committerJames Le Cuirot <chewi@gentoo.org>2024-08-26 23:11:18 +0100
commitb7c1c7a69cf9f36a15eb387384cbc964a72b709b (patch)
treecad406be60923343b295e20f047ea7d3532bcd55 /games-arcade/cosmosmash
parentgames-arcade/burgerspace: add 1.10.0 (diff)
downloadgentoo-b7c1c7a69cf9f36a15eb387384cbc964a72b709b.tar.gz
gentoo-b7c1c7a69cf9f36a15eb387384cbc964a72b709b.tar.bz2
gentoo-b7c1c7a69cf9f36a15eb387384cbc964a72b709b.zip
games-arcade/cosmosmash: add 1.5.0
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-arcade/cosmosmash')
-rw-r--r--games-arcade/cosmosmash/Manifest1
-rw-r--r--games-arcade/cosmosmash/cosmosmash-1.5.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/games-arcade/cosmosmash/Manifest b/games-arcade/cosmosmash/Manifest
index 1ebc55d1d255..a9c545691db9 100644
--- a/games-arcade/cosmosmash/Manifest
+++ b/games-arcade/cosmosmash/Manifest
@@ -1 +1,2 @@
DIST cosmosmash-1.4.8.tar.gz 921859 BLAKE2B 601ccf0eaf429bee240a6a07534afc44cb5bac390bedfc2548668048b8a5d93229e36de1c0e73856e3588d35cf7cfc6dbb00ac428fcc42612676281dcfaf0896 SHA512 4b78cac18035ef4bdbdebd2a206ceb3c80646fa030f568e171208af7510a6b1da9ef3fd817f3ebae83fbb42b1ce2900e8f1ff33ec23a8fe735022409ab1120af
+DIST cosmosmash-1.5.0.tar.gz 536986 BLAKE2B 07011857fdee30c104847e9ad2066795116fa2123c38184573d8b5a11154bbebe8991c6c51241658a65f23e20582e9759798bc986a3c4d9dee1c613f8400f333 SHA512 3be4b535d68eca185d3f48ff04c11c912fdcbc17470848650b20410030c7619f9dcffaeaf3bacb3a95eb37c5944724af7fc9978613c3252af1ec725504129c23
diff --git a/games-arcade/cosmosmash/cosmosmash-1.5.0.ebuild b/games-arcade/cosmosmash/cosmosmash-1.5.0.ebuild
new file mode 100644
index 000000000000..5b77da676179
--- /dev/null
+++ b/games-arcade/cosmosmash/cosmosmash-1.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Space rock shooting video game"
+HOMEPAGE="https://perso.b2b2c.ca/~sarrazip/dev/cosmosmash.html"
+SRC_URI="http://perso.b2b2c.ca/~sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # uses the sound card which portage user might not be available.
+
+RDEPEND=">=dev-games/flatzebra-0.2.0
+ media-libs/libsdl[joystick]
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
+ -e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
+ -e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
+ src/Makefile.am \
+ || die
+
+ eautoreconf
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install
+
+ einstalldocs
+ doman doc/${PN}.6
+}