summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/swordandsworcery
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/swordandsworcery')
-rw-r--r--games-action/swordandsworcery/Manifest1
-rw-r--r--games-action/swordandsworcery/files/swordandsworcery-wrapper23
-rw-r--r--games-action/swordandsworcery/metadata.xml11
-rw-r--r--games-action/swordandsworcery/swordandsworcery-1.02.ebuild109
4 files changed, 144 insertions, 0 deletions
diff --git a/games-action/swordandsworcery/Manifest b/games-action/swordandsworcery/Manifest
new file mode 100644
index 000000000000..a38a1603b279
--- /dev/null
+++ b/games-action/swordandsworcery/Manifest
@@ -0,0 +1 @@
+DIST swordandsworcery_1.02.tar.gz 325277619 SHA256 e7be30816059d5fa0bda2378d06f51984de13a17abd835cdc015e591354f59de SHA512 1178492628e8b8196bbb57b3d4d7526d5545bd31d0da34bcbed92150753fbb768c8682f071e2a473b95f1b6ee7c3efb30ccb9fce2e3e319d76673b79617e47c0 WHIRLPOOL 9ec0365372a62b7fadfa6b68e945918a1a2ade3c5e7bae561e16251ed0bf4e76b176bfed31e30b259e9a569858d1ae0b07a83067375ca26fe2da049602a570fd
diff --git a/games-action/swordandsworcery/files/swordandsworcery-wrapper b/games-action/swordandsworcery/files/swordandsworcery-wrapper
new file mode 100644
index 000000000000..ce668c71843a
--- /dev/null
+++ b/games-action/swordandsworcery/files/swordandsworcery-wrapper
@@ -0,0 +1,23 @@
+#!/bin/sh
+# Get game directory
+GAMEDIR="@GAMEDIR@"
+LIB=$GAMEDIR/lib
+BIN=$GAMEDIR/bin
+
+# Ensure the log directory exists
+LOGDIR=~/.capy/SwordAndSworcery
+[ -e ~/.capy ] || mkdir ~/.capy
+[ -e ~/.capy/SwordAndSworcery ] || mkdir ~/.capy/SwordAndSworcery
+
+# For multi-monitor displays, choose a screen to display on to avoid having
+# the game be displayed in the middle across both screens in fullscreen mode
+#export SDL_VIDEO_FULLSCREEN_DISPLAY=0
+
+# Modify library paths here
+export LD_LIBRARY_PATH="$LIB:$LD_LIBRARY_PATH"
+
+# Run the game and try to log any errors if any
+cd "$BIN"
+exec ./swordandsworcery $@ 2>&1 | tee -a $LOGDIR/log.txt
+
+exit
diff --git a/games-action/swordandsworcery/metadata.xml b/games-action/swordandsworcery/metadata.xml
new file mode 100644
index 000000000000..d13413d31d91
--- /dev/null
+++ b/games-action/swordandsworcery/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>
+
diff --git a/games-action/swordandsworcery/swordandsworcery-1.02.ebuild b/games-action/swordandsworcery/swordandsworcery-1.02.ebuild
new file mode 100644
index 000000000000..5813b997d32c
--- /dev/null
+++ b/games-action/swordandsworcery/swordandsworcery-1.02.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: unbundle liblua-5.1 when available for multilib
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="An exploratory action adventure game with an emphasis on audiovisual style"
+HOMEPAGE="http://www.swordandsworcery.com/"
+SRC_URI="${PN}_${PV}.tar.gz"
+
+LICENSE="CAPYBARA-EULA LGPL-3"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/bin/*
+ ${MYGAMEDIR#/}/lib/*"
+
+# linked to pulseaudio
+RDEPEND="
+ virtual/opengl
+ amd64? (
+ >=dev-libs/openssl-1.0.1h-r2[abi_x86_32(-)]
+ >=sys-libs/zlib-1.2.8-r1[abi_x86_32(-)]
+ >=virtual/glu-9.0-r1[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/alsa-lib-1.0.27.2[abi_x86_32(-)]
+ >=media-libs/flac-1.2.1-r5[abi_x86_32(-)]
+ >=media-libs/libogg-1.3.0[abi_x86_32(-)]
+ >=media-libs/libsndfile-1.0.25[abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ >=media-sound/pulseaudio-2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libICE-1.0.8-r1[abi_x86_32(-)]
+ >=x11-libs/libSM-1.2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXau-1.0.7-r1[abi_x86_32(-)]
+ >=x11-libs/libxcb-1.9.1[abi_x86_32(-)]
+ >=x11-libs/libXdmcp-1.1.1-r1[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+ >=x11-libs/libXtst-1.2.1-r1[abi_x86_32(-)]
+ !bundled-libs? (
+ >=net-misc/curl-7.36.0[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[X,sound,video,opengl,joystick,abi_x86_32(-)]
+ )
+ )
+ x86? (
+ dev-libs/openssl
+ media-libs/alsa-lib
+ media-libs/flac
+ media-libs/libogg
+ media-libs/libsndfile
+ media-libs/libvorbis
+ media-sound/pulseaudio
+ sys-libs/zlib
+ virtual/glu
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXtst
+ !bundled-libs? (
+ net-misc/curl
+ media-libs/libsdl[X,sound,video,opengl,joystick]
+ )
+ )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ if ! use bundled-libs ; then
+ einfo "removing bundled libs..."
+ rm -v lib/libcurl.so* lib/libSDL-1.2.so* \
+ lib/libstdc++.so* || die
+ fi
+
+ sed \
+ -e "s#@GAMEDIR@#${MYGAMEDIR}#" \
+ "${FILESDIR}"/${PN}-wrapper > "${T}"/${PN} || die
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r bin lib res
+
+ dogamesbin "${T}"/${PN}
+ make_desktop_entry ${PN}
+
+ dohtml README.html
+
+ fperms +x "${MYGAMEDIR}"/bin/${PN}
+ prepgamesdirs
+}