summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-25 13:41:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-25 14:08:51 +0200
commit37cfea4ba8f3679c66580e6dc8474e84bf9840dc (patch)
tree350b62a24c8e96809001390ab350bc57f50feaf4 /eclass
parentdev-python/adblock: migrate to distutils-r1 with PEP517=maturin (diff)
downloadgentoo-37cfea4ba8f3679c66580e6dc8474e84bf9840dc.tar.gz
gentoo-37cfea4ba8f3679c66580e6dc8474e84bf9840dc.tar.bz2
gentoo-37cfea4ba8f3679c66580e6dc8474e84bf9840dc.zip
distutils-r1.eclass: Limit dev-python/installer version
dev-python/installer has made incompatible changes in 0.5.1 that breaks the non-gpep517 code path. Add a version limit prior to bumping, in case we end up reverting gpep517 changes. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass1
1 files changed, 1 insertions, 0 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 49c98290f30f..9e6c18c55716 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -195,6 +195,7 @@ _distutils_set_globals() {
# installer is used to install the wheel
# tomli is used to read build-backend from pyproject.toml
bdep='
+ <dev-python/installer-0.5.1[${PYTHON_USEDEP}]
>=dev-python/installer-0.4.0_p20220124[${PYTHON_USEDEP}]
>=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]'
case ${DISTUTILS_USE_PEP517} in