summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-16 18:12:31 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-16 20:24:45 +0200
commit70fd6ae560a759cf83d80360f709a4be4829524d (patch)
treefb2342ba97a96d371e49c51d8df3a90036652520 /dev-vcs
parentsys-cluster/singularity: bump to 3.7.3 (diff)
downloadgentoo-70fd6ae560a759cf83d80360f709a4be4829524d.tar.gz
gentoo-70fd6ae560a759cf83d80360f709a4be4829524d.tar.bz2
gentoo-70fd6ae560a759cf83d80360f709a4be4829524d.zip
dev-vcs/pre-commit: use pytest-env now that it is in the tree
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.12.0.ebuild19
1 files changed, 4 insertions, 15 deletions
diff --git a/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild
index 8dc97acfe007..c494bc22f847 100644
--- a/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-2.12.0.ebuild
@@ -25,8 +25,6 @@ KEYWORDS="~amd64"
# Ditto
# - tests/commands/install_uninstall_test.py::test_installed_from_venv
# "git commit" returns 1 instead of 0, again no details
-# even with the environment variables normally handled by pytest-env (which we haven't got in the tree yet)
-# explicitly declared in python_test().
#RESTRICT="test"
RDEPEND="dev-vcs/git
@@ -39,7 +37,10 @@ RDEPEND="dev-vcs/git
>=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
')"
BDEPEND="test? (
- $(python_gen_cond_dep 'dev-python/re-assert[${PYTHON_USEDEP}]')
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
)"
DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
@@ -53,15 +54,3 @@ src_prepare() {
# and while some of them do include "skip if not found" logic, most of them do not.
rm -rf tests/languages tests/repository_test.py
}
-
-python_test() {
- # TODO: add pytest-env to the tree so that these can be read from tox.ini
- declare -x GIT_AUTHOR_NAME=test
- declare -x GIT_COMMITTER_NAME=test
- declare -x GIT_AUTHOR_EMAIL=test@example.com
- declare -x GIT_COMMITTER_EMAIL=test@example.com
- declare -x VIRTUALENV_NO_DOWNLOAD=1
- declare -x PRE_COMMIT_NO_CONCURRENCY=1
-
- distutils-r1_python_test
-}