summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-08-31 14:16:53 +0100
committerMarek Szuba <marecki@gentoo.org>2022-08-31 14:17:28 +0100
commit3cc5234252ebc76b21449286f515c2f01a357600 (patch)
tree227880badecc3e68ed2fd9d36376f18b9719f82c /dev-vcs
parentdev-python/trio-asyncio: update EAPI 7 -> 8, pep517 (diff)
downloadgentoo-3cc5234252ebc76b21449286f515c2f01a357600.tar.gz
gentoo-3cc5234252ebc76b21449286f515c2f01a357600.tar.bz2
gentoo-3cc5234252ebc76b21449286f515c2f01a357600.zip
dev-vcs/git-machete: initial import, version 3.12.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-machete/Manifest1
-rw-r--r--dev-vcs/git-machete/git-machete-3.12.0.ebuild46
-rw-r--r--dev-vcs/git-machete/metadata.xml26
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-vcs/git-machete/Manifest b/dev-vcs/git-machete/Manifest
new file mode 100644
index 000000000000..7ef3fd6c958f
--- /dev/null
+++ b/dev-vcs/git-machete/Manifest
@@ -0,0 +1 @@
+DIST git-machete-3.12.0.gh.tar.gz 1377199 BLAKE2B 82c4287efe902f6571504a5b2a793aa3c1b61a526db4262456bd617897b16e30ba2713f7900fa8482f7b30b75e6b76257cefaed154ec41e7e54f3097565a60bc SHA512 6a6168c7d8f0fb406b1ddb471f280a31dac4406a058006b62f4a4d8b5f8e1b681e460a59671acd091cf8411c1d3050c175544a4e18f21522297811c89ac9a271
diff --git a/dev-vcs/git-machete/git-machete-3.12.0.ebuild b/dev-vcs/git-machete/git-machete-3.12.0.ebuild
new file mode 100644
index 000000000000..a4233157cd39
--- /dev/null
+++ b/dev-vcs/git-machete/git-machete-3.12.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Probably the sharpest git repository organizer & rebase/merge workflow automation tool you've ever seen"
+HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="fish-completion zsh-completion"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ >=dev-python/pytest-mock-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ ')
+)"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp completion/${PN}.completion.bash ${PN}
+ if use fish-completion; then
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/${PN}.fish
+ fi
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins completion/${PN}.completion.zsh _${PN}
+ fi
+}
diff --git a/dev-vcs/git-machete/metadata.xml b/dev-vcs/git-machete/metadata.xml
new file mode 100644
index 000000000000..8199593ab959
--- /dev/null
+++ b/dev-vcs/git-machete/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ git-machete is a robust tool that simplifies your git workflows.
+
+ The bird's eye view provided by git-machete makes merges/rebases/push/pulls
+ hassle-free even when multiple branches are present in the repository
+ (master/develop, your topic branches, teammate's branches checked out
+ for review, etc.).
+
+ Using this tool, you can maintain small, focused, easy-to-review pull
+ requests with little effort.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">VirtusLab/git-machete</remote-id>
+ <remote-id type="pypi">git-machete</remote-id>
+ </upstream>
+ <use>
+ <flag name="fish-completion">Enable fish completion support</flag>
+ </use>
+</pkgmetadata>