summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/hub
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/hub')
-rw-r--r--dev-vcs/hub/Manifest2
-rw-r--r--dev-vcs/hub/hub-1.12.4.ebuild53
-rw-r--r--dev-vcs/hub/hub-2.2.0-r1.ebuild41
-rw-r--r--dev-vcs/hub/metadata.xml15
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-vcs/hub/Manifest b/dev-vcs/hub/Manifest
new file mode 100644
index 000000000000..1a3621987e07
--- /dev/null
+++ b/dev-vcs/hub/Manifest
@@ -0,0 +1,2 @@
+DIST hub-1.12.4.tar.gz 76798 SHA256 b7fe404d7dc5f60554f088bec12de5e80229331430ea0ced46d5bf89ecae5117 SHA512 3c80592954f6f9bd9406adf8faaaf3e307a5387b623b07f06f574e6841899a7e253b67429417ba37c78b53064ddd0188b9f37e3e24130d899207c23bad389618 WHIRLPOOL 46c0870101add366c83d12ea92cfd1d434e841df58101ef8b1250e040cb0fe92590245b3e092780213b837cc2f9d9ad9bd9bff37a110bc608d63cddd7bbf4898
+DIST hub-2.2.0.tar.gz 301460 SHA256 2da1351197eb5696c207f22c69a5422af052d74277b73d0b8661efb9ec1d0eb1 SHA512 ad65cfd2a81ab92ab69d31ff7a068cf2da1557ca1d2f6e1b97b7f939249e9955bb2cace42b8900ec2d5b98970fbca27435edcd503af7ee3c05a79462e7734d8a WHIRLPOOL 83ea1d3b1086d7cdcebed6cb604027763cd41dd3f101dd56827c469ec61034a9e3a7b4cbd1111b5b7820707a13679a558704d80d58fed125f07573fb983dff9a
diff --git a/dev-vcs/hub/hub-1.12.4.ebuild b/dev-vcs/hub/hub-1.12.4.ebuild
new file mode 100644
index 000000000000..1415d6bb713e
--- /dev/null
+++ b/dev-vcs/hub/hub-1.12.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+RUBY_FAKEGEM_TASK_DOC=
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit bash-completion-r1 readme.gentoo ruby-fakegem
+
+DESCRIPTION="Command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+RDEPEND+=" dev-vcs/git"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/webmock
+ dev-util/cucumber
+ dev-ruby/minitest:5
+ )"
+
+DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+
+all_ruby_prepare() {
+ # Git's manpage changed, so this test will fail
+ sed -i -e '/test_help_custom_command/,+4 s/^/#/' test/hub_test.rb || die
+}
+
+src_install() {
+ ruby-ng_src_install
+ readme.gentoo_create_doc
+
+ cd "${S}"/all/${P} || die
+
+ doman man/${PN}.1
+
+ insinto /usr/share/${PN}/
+ doins -r git-hooks
+
+ # Broken with autoloader
+ # https://github.com/github/hub/issues/592
+ #newbashcomp etc/hub.bash_completion.sh ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins etc/hub.zsh_completion ${PN}
+}
diff --git a/dev-vcs/hub/hub-2.2.0-r1.ebuild b/dev-vcs/hub/hub-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..f5240aec72dd
--- /dev/null
+++ b/dev-vcs/hub/hub-2.2.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1 readme.gentoo
+
+DESCRIPTION="Command-line wrapper for git that makes you better at GitHub"
+HOMEPAGE="https://github.com/github/hub"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-lang/go-1.4:="
+RDEPEND=">=dev-vcs/git-1.7.3"
+
+DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
+
+src_compile() {
+ ./script/build || die
+}
+
+src_install() {
+ readme.gentoo_create_doc
+
+ dobin hub
+
+ doman man/${PN}.1
+ dodoc README.md
+
+ # Broken with autoloader
+ # https://github.com/github/hub/issues/592
+ # newbashcomp etc/${PN}.bash_completion.sh ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins etc/hub.zsh_completion _${PN}
+}
diff --git a/dev-vcs/hub/metadata.xml b/dev-vcs/hub/metadata.xml
new file mode 100644
index 000000000000..b8c73ab5785a
--- /dev/null
+++ b/dev-vcs/hub/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury</name>
+ </maintainer>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">defunkt/hub</remote-id>
+ </upstream>
+</pkgmetadata>