summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2025-01-26 19:38:11 +0100
committerUlrich Müller <ulm@gentoo.org>2025-01-26 19:39:02 +0100
commit20360ad724239af7cf70293b3419cd026f6a2c0e (patch)
tree17f0bc9f7a2f5b635e8998297be760c8b158db59 /dev-vcs/cvs-fast-export
parentapp-containers/docker-credential-helpers: drop 0.6.3 (diff)
downloadgentoo-20360ad724239af7cf70293b3419cd026f6a2c0e.tar.gz
gentoo-20360ad724239af7cf70293b3419cd026f6a2c0e.tar.bz2
gentoo-20360ad724239af7cf70293b3419cd026f6a2c0e.zip
dev-vcs/cvs-fast-export: add 1.68
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-vcs/cvs-fast-export')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.68.ebuild38
-rw-r--r--dev-vcs/cvs-fast-export/files/cvs-fast-export-1.68-Makefile.patch20
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index 764f0b2ef4db..d7a298d02061 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1,2 +1,3 @@
DIST cvs-fast-export-1.61.tar.gz 525785 BLAKE2B 64089fe0f99e247505152ad20c618a721917fabcf28e29ede330e89d9ffc3b05e314e09deb85c9c23de95acfa6193a6dd67636374862d58df231e06fd8313f09 SHA512 505a305b3f383a9df0f519ec0bbf92d5fbd2759b5be39b3eced898a00bd06290f2905e6add49c992ff69fdf468f6c83e15e8810bdf12d08eec0289aa7930df4e
DIST cvs-fast-export-1.67.tar.gz 575386 BLAKE2B 080ca91d1002707dfc81d2d87373cb47b314b7f59dfb49081f4279b6d97ca43165d5dceb827e281deeae4d617bdec062475afb652b2680124c03455e155e9151 SHA512 193ae2a9ded2052d393891e0d847ca28a6b955fb17396d31c84265ff4336a9eb769d290fbdb645b7a528b17235e1a9a611d8b703977037229c001e6e46129445
+DIST cvs-fast-export-1.68.tar.gz 589722 BLAKE2B 2e904c60c7431a64afe24bfc8d57d8eb533d41c5905423a656f6ed2c3b6d0a646466941c94d002351c3b3bd336e3d846c3dba8cfd22f9256fd79d4db6f5dd64c SHA512 2e3eb1f305aa05320ba244cb34816dc3378caeb5bc0de6b2991f001f28d7eea7dc48d1bca297a38c934671a942be0bc810fc711aff8950461582a064d7a198d9
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.68.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.68.ebuild
new file mode 100644
index 000000000000..e5c66a2f9f9f
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.68.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # upstream does not ship some tests in tarball
+
+BDEPEND="dev-ruby/asciidoctor"
+
+PATCHES=( "${FILESDIR}/${PN}-1.68-Makefile.patch" )
+
+src_prepare() {
+ default
+ tc-export CC
+ export prefix="${EPREFIX}"/usr
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc {NEWS,README,TODO,hacking,reporting-bugs}.adoc
+}
diff --git a/dev-vcs/cvs-fast-export/files/cvs-fast-export-1.68-Makefile.patch b/dev-vcs/cvs-fast-export/files/cvs-fast-export-1.68-Makefile.patch
new file mode 100644
index 000000000000..e0f63c0c7d6c
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/files/cvs-fast-export-1.68-Makefile.patch
@@ -0,0 +1,20 @@
+--- cvs-fast-export-1.68/Makefile
++++ cvs-fast-export-1.68/Makefile
+@@ -38,7 +38,7 @@
+ GCC_WARNINGS1=-Wall -Wextra -Werror -Wpointer-arith -Wstrict-prototypes
+ GCC_WARNINGS3=-Wno-format-zero-length
+ GCC_WARNINGS=$(GCC_WARNINGS1) $(GCC_WARNINGS2) $(GCC_WARNINGS3)
+-CFLAGS += $(GCC_WARNINGS)
++#CFLAGS += $(GCC_WARNINGS)
+ CPPFLAGS += -I.
+ #LIBS=-lrt
+ CPPFLAGS += -DVERSION=\"$(VERSION)\"
+@@ -70,7 +70,7 @@
+ # CFLAGS += -pg
+ # Warning: Using -O3 has been seen to cause core dumps on repositories with
+ # very long revision names - some bounds check gets optimized away. Don't do that.
+-CFLAGS += -O2
++#CFLAGS += -O2
+ # If your toolchain supports link time optimization this is a cheap speedup
+ # CFLAGS += -flto
+ # Bounds checks at runtime. Not enabled by default for performance reasons