summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-02-29 21:21:34 +0200
committerMart Raudsepp <leio@gentoo.org>2020-02-29 23:21:46 +0200
commita51bf967fdf71b30a8ee3a938ad0bcaec419eeac (patch)
tree3273b97b6c4bb411406e7cd298db8d963c2e2354 /dev-util
parentdev-util/gnome-builder-3.32: USE=sysprof requires sysprof-2.pc (subslot 0) (diff)
downloadgentoo-a51bf967fdf71b30a8ee3a938ad0bcaec419eeac.tar.gz
gentoo-a51bf967fdf71b30a8ee3a938ad0bcaec419eeac.tar.bz2
gentoo-a51bf967fdf71b30a8ee3a938ad0bcaec419eeac.zip
dev-util/sysprof-capture: initial split from dev-util/sysprof
Now with sysprof-capture-3.pc API, other GNOME components start to more widely make use of providing their own capture data, for which they use this sysprof-capture static library helper. This includes x11-libs/gtk+, which would be an out of the box circular dependency if sysprof-capture is kept as part of full dev-util/sysprof package. Add a split package as really intended, which gtk+, mutter and others can DEPEND on (but don't need to RDEPEND), probably even by default. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/sysprof-capture/Manifest1
-rw-r--r--dev-util/sysprof-capture/metadata.xml8
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild50
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/Manifest b/dev-util/sysprof-capture/Manifest
new file mode 100644
index 000000000000..c718e91a09e2
--- /dev/null
+++ b/dev-util/sysprof-capture/Manifest
@@ -0,0 +1 @@
+DIST sysprof-3.34.1.tar.xz 372612 BLAKE2B 3a50a00f29866ae8bf03cc7a57b598e40a6a37ad88ac2159087e4f2a8a6a5cef09b345dc5332fb1df9036c4e159e98f19adda45588150b059af313878b9b554c SHA512 5f2d820935291a3b578222d5daa87b0a2f74cd16d14daca19065495be61cf7359f00f12f452a5c0b4e05dfeb94e2376017c2288cad92dc0c4bb9bca51b903d19
diff --git a/dev-util/sysprof-capture/metadata.xml b/dev-util/sysprof-capture/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/dev-util/sysprof-capture/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild
new file mode 100644
index 000000000000..fb4cdee37666
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.34.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.61.3:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # In 3.34.1 -Dlibsysprof=false still installs various data files related with it;
+ # some of these seem fixed by 3.36
+ sed -i -e '/subdir.*data/d' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # In 3.36 these shouldn't be needed with with_sysprofd=none
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof2.xml || die
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml || die
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml || die
+}