summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2023-06-01 09:49:22 +0200
committerIonen Wolkens <ionen@gentoo.org>2023-06-01 08:06:26 -0400
commit6d0a914e801f82b49699f7198ddf2832982cff72 (patch)
treecbb035420b8704bb08e3d2d3a6ded1945901f3c7 /dev-util
parentdev-util/scap-driver: EAPI7->8, migrate to linux-mod-r1 (diff)
downloadgentoo-6d0a914e801f82b49699f7198ddf2832982cff72.tar.gz
gentoo-6d0a914e801f82b49699f7198ddf2832982cff72.tar.bz2
gentoo-6d0a914e801f82b49699f7198ddf2832982cff72.zip
dev-util/scap-driver: clean up old
Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/31260 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/scap-driver/scap-driver-0.29.3-r1.ebuild59
-rw-r--r--dev-util/scap-driver/scap-driver-0.29.3-r2.ebuild60
-rw-r--r--dev-util/scap-driver/scap-driver-0.29.3-r3.ebuild61
3 files changed, 0 insertions, 180 deletions
diff --git a/dev-util/scap-driver/scap-driver-0.29.3-r1.ebuild b/dev-util/scap-driver/scap-driver-0.29.3-r1.ebuild
deleted file mode 100644
index 3006d1559d7a..000000000000
--- a/dev-util/scap-driver/scap-driver-0.29.3-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake linux-mod
-
-DESCRIPTION="Kernel module for dev-util/sysdig"
-HOMEPAGE="https://sysdig.com/"
-
-# The driver is part of falcosecurity/libs, but for versioning reasons we cannot (yet)
-# use semver-released packages; instead we pull in a commit that is used and known
-# to work with sysdig, see sysdig/cmake/modules/falcosecurity-libs.cmake for details.
-# For now the commit here and the one referenced in sysdig should be in sync.
-LIBS_COMMIT="e5c53d648f3c4694385bbe488e7d47eaa36c229a"
-SRC_URI="https://github.com/falcosecurity/libs/archive/${LIBS_COMMIT}.tar.gz -> falcosecurity-libs-${LIBS_COMMIT}.tar.gz"
-S="${WORKDIR}/libs-${LIBS_COMMIT}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="!<dev-util/sysdig-${PV}[modules]"
-
-CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-fix-kmod-build-on-5.18+.patch
- "${FILESDIR}"/${PV}-fix-kmod-build-on-6.2+.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- # we will use linux-mod, so just pretend to use bundled deps
- # in order to make it through the cmake setup.
- -DUSE_BUNDLED_DEPS=ON
- -DCREATE_TEST_TARGETS=OFF
- -DDRIVER_VERSION=${LIBS_COMMIT}
- )
-
- cmake_src_configure
-
- # setup linux-mod ugliness
- MODULE_NAMES="scap(extra:${BUILD_DIR}/driver/src:)"
- BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
- # work with clang-built kernels (#816024)
- if linux_chkconfig_present CC_IS_CLANG; then
- BUILD_PARAMS+=' CC=${CHOST}-clang'
- if linux_chkconfig_present LD_IS_LLD; then
- BUILD_PARAMS+=' LD=ld.lld'
- if linux_chkconfig_present LTO_CLANG_THIN; then
- # kernel enables cache by default leading to sandbox violations
- BUILD_PARAMS+=' ldflags-y=--thinlto-cache-dir= LDFLAGS_MODULE=--thinlto-cache-dir='
- fi
- fi
- fi
-
- BUILD_TARGETS="all"
-}
diff --git a/dev-util/scap-driver/scap-driver-0.29.3-r2.ebuild b/dev-util/scap-driver/scap-driver-0.29.3-r2.ebuild
deleted file mode 100644
index 129db40bcb86..000000000000
--- a/dev-util/scap-driver/scap-driver-0.29.3-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake linux-mod
-
-DESCRIPTION="Kernel module for dev-util/sysdig"
-HOMEPAGE="https://sysdig.com/"
-
-# The driver is part of falcosecurity/libs, but for versioning reasons we cannot (yet)
-# use semver-released packages; instead we pull in a commit that is used and known
-# to work with sysdig, see sysdig/cmake/modules/falcosecurity-libs.cmake for details.
-# For now the commit here and the one referenced in sysdig should be in sync.
-LIBS_COMMIT="e5c53d648f3c4694385bbe488e7d47eaa36c229a"
-SRC_URI="https://github.com/falcosecurity/libs/archive/${LIBS_COMMIT}.tar.gz -> falcosecurity-libs-${LIBS_COMMIT}.tar.gz"
-S="${WORKDIR}/libs-${LIBS_COMMIT}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="!<dev-util/sysdig-${PV}[modules]"
-
-CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-fix-kmod-build-on-5.18+.patch
- "${FILESDIR}"/${PV}-fix-kmod-build-on-6.2+.patch
- "${FILESDIR}"/${PV}-fix-kmod-build-on-6.3+.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- # we will use linux-mod, so just pretend to use bundled deps
- # in order to make it through the cmake setup.
- -DUSE_BUNDLED_DEPS=ON
- -DCREATE_TEST_TARGETS=OFF
- -DDRIVER_VERSION=${LIBS_COMMIT}
- )
-
- cmake_src_configure
-
- # setup linux-mod ugliness
- MODULE_NAMES="scap(extra:${BUILD_DIR}/driver/src:)"
- BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
- # work with clang-built kernels (#816024)
- if linux_chkconfig_present CC_IS_CLANG; then
- BUILD_PARAMS+=' CC=${CHOST}-clang'
- if linux_chkconfig_present LD_IS_LLD; then
- BUILD_PARAMS+=' LD=ld.lld'
- if linux_chkconfig_present LTO_CLANG_THIN; then
- # kernel enables cache by default leading to sandbox violations
- BUILD_PARAMS+=' ldflags-y=--thinlto-cache-dir= LDFLAGS_MODULE=--thinlto-cache-dir='
- fi
- fi
- fi
-
- BUILD_TARGETS="all"
-}
diff --git a/dev-util/scap-driver/scap-driver-0.29.3-r3.ebuild b/dev-util/scap-driver/scap-driver-0.29.3-r3.ebuild
deleted file mode 100644
index deb27234ee35..000000000000
--- a/dev-util/scap-driver/scap-driver-0.29.3-r3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake linux-mod
-
-DESCRIPTION="Kernel module for dev-util/sysdig"
-HOMEPAGE="https://sysdig.com/"
-
-# The driver is part of falcosecurity/libs, but for versioning reasons we cannot (yet)
-# use semver-released packages; instead we pull in a commit that is used and known
-# to work with sysdig, see sysdig/cmake/modules/falcosecurity-libs.cmake for details.
-# For now the commit here and the one referenced in sysdig should be in sync.
-LIBS_COMMIT="e5c53d648f3c4694385bbe488e7d47eaa36c229a"
-SRC_URI="https://github.com/falcosecurity/libs/archive/${LIBS_COMMIT}.tar.gz -> falcosecurity-libs-${LIBS_COMMIT}.tar.gz"
-S="${WORKDIR}/libs-${LIBS_COMMIT}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="!<dev-util/sysdig-${PV}[modules]"
-
-CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-fix-kmod-build-on-5.18+.patch
- "${FILESDIR}"/${PV}-fix-kmod-build-on-6.2+.patch
- "${FILESDIR}"/${PV}-fix-kmod-build-on-6.3+.patch
- "${FILESDIR}"/${PV}-fix-kmod-build-on-6.4+.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- # we will use linux-mod, so just pretend to use bundled deps
- # in order to make it through the cmake setup.
- -DUSE_BUNDLED_DEPS=ON
- -DCREATE_TEST_TARGETS=OFF
- -DDRIVER_VERSION=${LIBS_COMMIT}
- )
-
- cmake_src_configure
-
- # setup linux-mod ugliness
- MODULE_NAMES="scap(extra:${BUILD_DIR}/driver/src:)"
- BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
- # work with clang-built kernels (#816024)
- if linux_chkconfig_present CC_IS_CLANG; then
- BUILD_PARAMS+=' CC=${CHOST}-clang'
- if linux_chkconfig_present LD_IS_LLD; then
- BUILD_PARAMS+=' LD=ld.lld'
- if linux_chkconfig_present LTO_CLANG_THIN; then
- # kernel enables cache by default leading to sandbox violations
- BUILD_PARAMS+=' ldflags-y=--thinlto-cache-dir= LDFLAGS_MODULE=--thinlto-cache-dir='
- fi
- fi
- fi
-
- BUILD_TARGETS="all"
-}