summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-03 07:04:27 +0100
committerSam James <sam@gentoo.org>2024-06-03 07:04:27 +0100
commit1b24ef9b2136c1fa5cefb47eedca17aaefefa471 (patch)
tree1c5eec28d457427823b01142bf483ecc88a39d66 /dev-util
parentdev-ruby/ffi: add 1.17.0 (diff)
downloadgentoo-1b24ef9b2136c1fa5cefb47eedca17aaefefa471.tar.gz
gentoo-1b24ef9b2136c1fa5cefb47eedca17aaefefa471.tar.bz2
gentoo-1b24ef9b2136c1fa5cefb47eedca17aaefefa471.zip
dev-util/umockdev: add 0.18.3
Also, filter -fno-semantic-interposition, as it doesn't play well with wrappers like this. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/umockdev/Manifest1
-rw-r--r--dev-util/umockdev/umockdev-0.18.3.ebuild62
-rw-r--r--dev-util/umockdev/umockdev-9999.ebuild7
3 files changed, 68 insertions, 2 deletions
diff --git a/dev-util/umockdev/Manifest b/dev-util/umockdev/Manifest
index 11fc9b425c3d..4d55746f5fd1 100644
--- a/dev-util/umockdev/Manifest
+++ b/dev-util/umockdev/Manifest
@@ -1,2 +1,3 @@
DIST umockdev-0.17.18.tar.xz 491668 BLAKE2B 106efc5674475383abb7618f087b3536441ae1fa30d6a92b689c1119ff62e06a20a6a529968f2b978f8ed410fc2033c95b86e214d4d4a576cdb9e68ee09a1853 SHA512 3d8d2487b4350e4ce28a5c163cbb1b92da9f5a5317e74da46ccaa62a6b8e938a6758e241d0dd2e9f50fdee4aef24d36585a24cfec1ad99fb4799a01008d9987b
DIST umockdev-0.18.1.tar.xz 493816 BLAKE2B 314969269e8e5b70b65c89345b659cf2784eb71cfd2c010e8043cc38b6965dce0dcadac6ffab266f4b926e46bb0939d6c159ee17fbf341eed7a11f932a80a2ad SHA512 4897c12fca8d1927a2840efbbd8281a95102b328cc682ffed10cd4e29b80f26b80df55fbd3736297ee4633561b007beda369bd3ddf07eb71bdd1d7c0222243c8
+DIST umockdev-0.18.3.tar.xz 493724 BLAKE2B 989391474b7204a228a323244b75dc81992c69cd79a499ea701344311a890383eb6d589769df2006727c371757e4bf807831b9ccabde0fcbfd1b99054042fdc6 SHA512 565fedc4367b7896ac4fd9cee19d704d1f3f8b382c31069ceef81d0a0e8f3a38b775f28bd7a3652a7bb9c5cb62dd1f616ea81d7fc2ee7fda933bad44b32627d2
diff --git a/dev-util/umockdev/umockdev-0.18.3.ebuild b/dev-util/umockdev/umockdev-0.18.3.ebuild
new file mode 100644
index 000000000000..c032e0519a4d
--- /dev/null
+++ b/dev-util/umockdev/umockdev-0.18.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit flag-o-matic meson-multilib python-any-r1 vala
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/martinpitt/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/martinpitt/umockdev/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Mock hardware devices for creating unit tests"
+HOMEPAGE="https://github.com/martinpitt/umockdev/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-libs/libpcap[${MULTILIB_USEDEP}]
+ virtual/libudev:=[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=dev-libs/gobject-introspection-1.32:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ ${PYTHON_DEPS}
+ dev-libs/libgudev:=[${MULTILIB_USEDEP}]
+ )
+"
+BDEPEND="
+ $(vala_depend)
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+multilib_src_configure() {
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101270
+ filter-flags -fno-semantic-interposition
+
+ export VALAC="$(type -P valac-$(vala_best_api_version))"
+ meson_src_configure
+}
+
+multilib_src_test() {
+ meson_src_test --no-suite fails-valgrind
+}
diff --git a/dev-util/umockdev/umockdev-9999.ebuild b/dev-util/umockdev/umockdev-9999.ebuild
index d9b79b4a0013..c032e0519a4d 100644
--- a/dev-util/umockdev/umockdev-9999.ebuild
+++ b/dev-util/umockdev/umockdev-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit meson-multilib python-any-r1 vala
+inherit flag-o-matic meson-multilib python-any-r1 vala
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/martinpitt/${PN}.git"
@@ -50,6 +50,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101270
+ filter-flags -fno-semantic-interposition
+
export VALAC="$(type -P valac-$(vala_best_api_version))"
meson_src_configure
}