summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-01 18:16:57 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-01 18:17:43 +0200
commit4bf1c50c0f6f86935a054e295da32c9db847c3c7 (patch)
tree843bf7394e29c89b9eead4b27d946f8bee87be8e /dev-util/sysprof
parentgnome-extra/gnome-documents: bump to 3.34.0 (diff)
downloadgentoo-4bf1c50c0f6f86935a054e295da32c9db847c3c7.tar.gz
gentoo-4bf1c50c0f6f86935a054e295da32c9db847c3c7.tar.bz2
gentoo-4bf1c50c0f6f86935a054e295da32c9db847c3c7.zip
dev-util/sysprof: bump to 3.34.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/sysprof')
-rw-r--r--dev-util/sysprof/Manifest1
-rw-r--r--dev-util/sysprof/metadata.xml3
-rw-r--r--dev-util/sysprof/sysprof-3.34.1.ebuild74
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
index d1fc06eee560..ca9f0fa98402 100644
--- a/dev-util/sysprof/Manifest
+++ b/dev-util/sysprof/Manifest
@@ -1 +1,2 @@
DIST sysprof-3.32.0.tar.xz 296052 BLAKE2B f409c64d40bd3451037e601683f270ff93ea2a60a2c104d22edc6bad5ff3f5c974f80137776b6329dae932852fa0871f2b7b9960a282147ddef5402ad840d9ef SHA512 7b9d84ac241d376a5e545082b1224e7db96af26ae0ee297d5f0b2d45abc4676e23009dbd560085e5d4879378a8dd79eefb4449df3961fbfd09238bd2056061d0
+DIST sysprof-3.34.1.tar.xz 372612 BLAKE2B 3a50a00f29866ae8bf03cc7a57b598e40a6a37ad88ac2159087e4f2a8a6a5cef09b345dc5332fb1df9036c4e159e98f19adda45588150b059af313878b9b554c SHA512 5f2d820935291a3b578222d5daa87b0a2f74cd16d14daca19065495be61cf7359f00f12f452a5c0b4e05dfeb94e2376017c2288cad92dc0c4bb9bca51b903d19
diff --git a/dev-util/sysprof/metadata.xml b/dev-util/sysprof/metadata.xml
index 70135f654431..2511f1c94370 100644
--- a/dev-util/sysprof/metadata.xml
+++ b/dev-util/sysprof/metadata.xml
@@ -17,4 +17,7 @@
<flag name="systemd">Build the sysprofd daemon service, required to run the UI without root permissions.
Relies on <pkg>sys-apps/systemd</pkg> for sd-bus API.</flag>
</use>
+<slots>
+ <subslots>sysprof and sysprof-ui API version</subslots>
+</slots>
</pkgmetadata>
diff --git a/dev-util/sysprof/sysprof-3.34.1.ebuild b/dev-util/sysprof/sysprof-3.34.1.ebuild
new file mode 100644
index 000000000000..069a3186fe30
--- /dev/null
+++ b/dev-util/sysprof/sysprof-3.34.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson systemd xdg
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+API_VERSION="3"
+SLOT="0/${API_VERSION}"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-libs/glib-2.61.3:2
+ gtk? (
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/libdazzle-3.30.0
+ )
+ >=sys-auth/polkit-0.114
+ dev-util/sysprof-capture:${API_VERSION}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ # These are installed by dev-util/sysprof-capture
+ sed -i -e '/install/d' src/libsysprof-capture/meson.build || die
+ sed -i -e 's/pkgconfig\.generate/subdir_done()\npkgconfig\.generate/' src/libsysprof-capture/meson.build || die
+}
+
+src_configure() {
+ # -Dwith_sysprofd=host currently unavailable from ebuild
+ local emesonargs=(
+ $(meson_use gtk enable_gtk)
+ -Dlibsysprof=true
+ -Dwith_sysprofd=bundled
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ elog "On many systems, especially amd64, it is typical that with a modern"
+ elog "toolchain -fomit-frame-pointer for gcc is the default, because"
+ elog "debugging is still possible thanks to gcc4/gdb location list feature."
+ elog "However sysprof is not able to construct call trees if frame pointers"
+ elog "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ elog "for the libraries and applications involved in the profiling. That"
+ elog "means a CPU register is used for the frame pointer instead of other"
+ elog "purposes, which means a very minimal performance loss when there is"
+ elog "register pressure."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}