summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-13 06:28:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-13 06:54:49 +0200
commit7ca69dbe6e3a4a132c18e1809ad31d78db335728 (patch)
tree56e71203f071b147168a40fcdf3a47dbcd1805f9 /dev-util/stripe-mock
parentdev-python/types-setuptools: Bump to 71.1.0.20240813 (diff)
downloadgentoo-7ca69dbe6e3a4a132c18e1809ad31d78db335728.tar.gz
gentoo-7ca69dbe6e3a4a132c18e1809ad31d78db335728.tar.bz2
gentoo-7ca69dbe6e3a4a132c18e1809ad31d78db335728.zip
dev-util/stripe-mock: Bump to 0.188.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.188.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index d26215261708..8e0f4ef734a6 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1,2 +1,3 @@
DIST stripe-mock-0.186.0.tar.gz 1617203 BLAKE2B a98ac19f23e9e15514c221df3e857a14bffc261e3e5d93cd8db1f821fdb37a97b49d74b9cadbcf752412b19a9757eed7c1d0e072b33eff83d40cce5d81f303be SHA512 7003eded0bc88442b3b8d66f6f943a2b438da783f1f3c8bccb1dc3c760f090e64faea08efd5ba544be7dc516657616f50040300c78f7ce10f2095d1e36576cc0
DIST stripe-mock-0.187.0.tar.gz 1664469 BLAKE2B d6e52fcf8b2c32f9e7203f34b7749a5166eefd3fd5a86a499566a47f149b4a94b2bb6144932324b30ab7781d7827aa71a1c9b9ab7d63be9e8ae4b541dbc74bb1 SHA512 b91eee52baf2952d9766af32af02691107986fdf87676684865161127c7262b3f13914a4a41f2de0b76c77a7ae9777b08a828379b8e7c6bc5521f2058475fa65
+DIST stripe-mock-0.188.0.tar.gz 1667602 BLAKE2B 0a26afc1865c2123f4aca4dc8231b74eef43972e8c1f43cb2196529c72feaa0143239c7c74ef34dc9a1cb543eec6ee328a96e45ca4515f488d89452dfbecefc7 SHA512 aaf2ed6619383d7eecdf43e93306b8523f4699ba6e0971724e69c1c0921d0c691ab5211a9e5efb642a7e7dd51324aef2996b663b622a1c346da9d80241a476ee
diff --git a/dev-util/stripe-mock/stripe-mock-0.188.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.188.0.ebuild
new file mode 100644
index 000000000000..352d14e2ce00
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.188.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}