summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-05 22:22:49 +0000
committerSam James <sam@gentoo.org>2021-03-05 22:22:49 +0000
commit5577e350d2715228112828058936896ec0535bdb (patch)
tree2c8669cab0d29e07f79faf12b835b728b82bcefc /dev-util/pkgdev
parentx11-libs/gnome-pty-helper: Stabilize 0.40.2 arm64, #765997 (diff)
downloadgentoo-5577e350d2715228112828058936896ec0535bdb.tar.gz
gentoo-5577e350d2715228112828058936896ec0535bdb.tar.bz2
gentoo-5577e350d2715228112828058936896ec0535bdb.zip
dev-util/pkgdev: bump 0.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/pkgdev')
-rw-r--r--dev-util/pkgdev/Manifest1
-rw-r--r--dev-util/pkgdev/pkgdev-0.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/pkgdev/Manifest b/dev-util/pkgdev/Manifest
new file mode 100644
index 000000000000..bd81701217d2
--- /dev/null
+++ b/dev-util/pkgdev/Manifest
@@ -0,0 +1 @@
+DIST pkgdev-0.1.tar.gz 26075 BLAKE2B e7f7a83d91ef923bdd38465e7c70d6a2d0693d945273583937b4f444e26493887c5aeff9cf6a353dc02c42786d635eda7cc0fbfbc888be2b0e4eee883b5bd9c6 SHA512 1714857c3d66655226a4217ec8955662c5e37022c92183bdd8e61f91ff46f335935af8d6badf79f7c9f894a56b970ab0109f9b18ac7f3e59722d096ce2f24664
diff --git a/dev-util/pkgdev/pkgdev-0.1.ebuild b/dev-util/pkgdev/pkgdev-0.1.ebuild
new file mode 100644
index 000000000000..587e2ad6a944
--- /dev/null
+++ b/dev-util/pkgdev/pkgdev-0.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgdev.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="Collection of tools for Gentoo development"
+HOMEPAGE="https://github.com/pkgcore/pkgdev"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]] ; then
+ # https://github.com/pkgcore/pkgdev/blob/main/requirements/dev.txt
+ RDEPEND="
+ ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
+ ~dev-util/pkgcheck-9999[${PYTHON_USEDEP}]
+ ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
+ "
+else
+ # https://github.com/pkgcore/pkgdev/blob/main/requirements/install.txt
+ RDEPEND="
+ >=dev-python/snakeoil-0.9.3[${PYTHON_USEDEP}]
+ >=dev-util/pkgcore-0.11.4[${PYTHON_USEDEP}]
+ >=sys-apps/pkgcore-0.9.1[${PYTHON_USEDEP}]
+ "
+fi
+
+RDEPEND+="dev-vcs/git"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_install_all() {
+ # We'll generate man pages ourselves
+ # Revisit when a release is made
+ # to pregenerate them, making USE=doc
+ # for generating the real HTML docs only.
+ if use doc ; then
+ cd doc || die
+ emake man
+ doman _build/man/*
+ fi
+
+ cd .. || die
+
+ # HTML pages only
+ sphinx_compile_all
+
+ distutils-r1_python_install_all
+}