summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-14 23:51:25 +0100
committerSam James <sam@gentoo.org>2024-08-14 23:52:59 +0100
commit23bb6a214c6c8ca046cf98387d5f4d25b3ccffe8 (patch)
treeb76ece3209cf1b094204b61e149dc6f00eea6daf /dev-util/pkgconf
parentnet-dns/c-ares: add 1.33.0 (diff)
downloadgentoo-23bb6a214c6c8ca046cf98387d5f4d25b3ccffe8.tar.gz
gentoo-23bb6a214c6c8ca046cf98387d5f4d25b3ccffe8.tar.bz2
gentoo-23bb6a214c6c8ca046cf98387d5f4d25b3ccffe8.zip
dev-util/pkgconf: add 2.3.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/pkgconf-2.3.0.ebuild73
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild2
3 files changed, 75 insertions, 1 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index 502abadd87b7..e9effa6ca376 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1,3 +1,4 @@
DIST pkgconf-1.8.1.tar.xz 302372 BLAKE2B 591961f0b1fd185834fd8e2a672199cffc035139599817b1d56d571300d2aa800a719c9477aac4023dfade597ad3cc3b45360babe57498977568ee57077c7bbe SHA512 7a7d5204c1c9bfb6578bda56f299d1fa0300e69a133a65730b10ad77aefbf26fceb74ae77cecda326b3ed5db5736f27fcce94764b3a56d40f4bb99fecdc80bba
DIST pkgconf-2.1.1.tar.xz 311956 BLAKE2B b59e57b1118bb75bc946a1e65e037a172c2ade3a7b9da8404b3598833cd091600045de151f2db06453b23563501b2dff7fdda8967e14c0c933ac50d28ddb3cd0 SHA512 cdf0998cd87f6d5e5a6560037eb847fd9613d237858d26eec321c42f54ca40ac72b6749c48c5b32611841d701393b1217bdb6c0cba5efd2c138be10d0e8fb32d
DIST pkgconf-2.2.0.tar.xz 311920 BLAKE2B c2a89e932e7671785799f4b82beb75e92f246c152c03e88c847cedef39f2123da0544ff914d1c1512b8616f8b8cfd9f5115b33560042bcfa7ac5f78c0ceb2a27 SHA512 c4ff254c7323bdebc2595037df60e33f17fc5c222d7500a4b9d8b18c8b451ac35cd3ac90d31c920c23e9495ece2b82422de61e13286d43de3a5d1fe8211bd944
+DIST pkgconf-2.3.0.tar.xz 316160 BLAKE2B cca3476df0b79cdbca798ed3a067611414e9b422e8347d0f490e7c4d0c43cdd2c7b586ac11e028a8df365d4ea4194f46b1d9fc0acd0f5fd6b4a5548673a8f853 SHA512 869fe0a7a2e06e9da37ff672b991dad60a9a7c9df2c65b78b2aa70dba10920650fb946d5a9c8019ea54a510835acc2eb4244092fa36d0339bd6764ff84e8542c
diff --git a/dev-util/pkgconf/pkgconf-2.3.0.ebuild b/dev-util/pkgconf/pkgconf-2.3.0.ebuild
new file mode 100644
index 000000000000..46f8e97f290d
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-2.3.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2012-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
+else
+ SRC_URI="https://distfiles.ariadne.space/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than C99"
+HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
+
+LICENSE="ISC"
+SLOT="0/5"
+IUSE="+native-symlinks test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+RDEPEND="!dev-util/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf$(get_exeext)
+ /usr/bin/pkg-config$(get_exeext)
+ )
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-system-includedir="${EPREFIX}/usr/include"
+ --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
+ default
+}
+
+multilib_src_install() {
+ default
+
+ dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
+ dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use native-symlinks; then
+ rm "${ED}"/usr/bin/{pkgconf,pkg-config}$(get_exeext) || die
+ fi
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index 51dd19d7b135..46f8e97f290d 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -17,7 +17,7 @@ DESCRIPTION="pkg-config compatible replacement with no dependencies other than C
HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
LICENSE="ISC"
-SLOT="0/4"
+SLOT="0/5"
IUSE="+native-symlinks test"
RESTRICT="!test? ( test )"