summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-10-21 13:00:38 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-10-21 13:01:06 -0500
commitb9a08f6bf4acde22f122d3de1202ef0cec61c7ce (patch)
tree7e38a3e164b852b5cad27cf83496cb3bd2cd8519 /dev-util/gitlab-runner
parentdev-util/gitlab-runner: add 17.4.1 (diff)
downloadgentoo-b9a08f6bf4acde22f122d3de1202ef0cec61c7ce.tar.gz
gentoo-b9a08f6bf4acde22f122d3de1202ef0cec61c7ce.tar.bz2
gentoo-b9a08f6bf4acde22f122d3de1202ef0cec61c7ce.zip
dev-util/gitlab-runner: add 17.5.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-17.5.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 0e356b02ac84..40db1fb676fb 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -6,3 +6,5 @@ DIST gitlab-runner-17.3.1-deps.tar.xz 86653516 BLAKE2B e7ac6d3218528f5a33f727a3e
DIST gitlab-runner-17.3.1.tar.bz2 1382824 BLAKE2B 58086f5964776ecc08d25c817e4460f5874f4b8def14aaab46f7e94157a2b801f42e0656c13190c3272fb43b3213ac253ed329563cf67e292a57f48d1fd0e7ce SHA512 67be67ed3e3c5136f6adad17c85080d6470f8a7082080fe7026609b42868de454dd1f8aa750087ecf23a02fdd1c2d00d7797638d0f9be070103574ea1a1c491b
DIST gitlab-runner-17.4.1-deps.tar.xz 104751932 BLAKE2B a4db4d8f739343a5648379d60717ec9df9526f481799dd4e8eb106167ea835a16e13b60d72a96a11d5d6ed9094ab099af82c86f061d8d85ea360d47e663876b7 SHA512 df4fdbdf242e52ca1ec1f54664646c5275561060b30e12c51d6ef41bdba5b8836e0c2a303b17ddead64dd946a9a01d191adbaadbf2f3eee7ebfc5bcda3746406
DIST gitlab-runner-17.4.1.tar.bz2 1407772 BLAKE2B 9185590409a53b511b12eb562d0765b95c202052fe2bc7c6aac334a298fd0af50cab3118079cfa42eb6ec0f7f767de0dadd036a5a888217f9742d8c5097a92e3 SHA512 be77f5e24aad129845cc0c66b19fe4cf673eb43e5a0b37a146d53a1cc114851340bfd08e23c78b8f9c4372ccee35dd541ac646abfd72906fb16c0d7fcca8e1d9
+DIST gitlab-runner-17.5.1-deps.tar.xz 108461592 BLAKE2B e78fc32c94f469267fb416f1f6d20341c7d06c46b21771ff35c6d46c5959d64d596c348df7f854a52c81bfae8c8ec3cedcecbf155be86ae832c66e3ce15abf45 SHA512 25d55ae1198415b1485a4209d19de034ad13cf25d300e50726cf67f69e27d8db3b02c664a631db3180a2ba192e9927dbba5fb5cdec7cfc35c7f5f56266f23836
+DIST gitlab-runner-17.5.1.tar.bz2 1725228 BLAKE2B 7aceaa08ac654b0e197eeac81828b505e940a0c37c1d47cee375858b650651277c4ce257f60106e845341252dccd9748d1c79fca5cac2cc151e08b9c4736b18c SHA512 f534bb38dfc42dcaa40067956a76680788d926e957f3fbf6bf763547428d0d896a2eb3360ed297c47fe2861d8fa992cf42e77346b552f4ed50fef9bb50f8cf93
diff --git a/dev-util/gitlab-runner/gitlab-runner-17.5.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-17.5.1.ebuild
new file mode 100644
index 000000000000..f8a323beb701
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-17.5.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=affd9e7d
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}