summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-08-16 21:10:11 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-08-16 21:10:29 -0500
commit997ae8e0f0b4ae5b164b214fb7e9238c75fcbdba (patch)
treef7eda7061af6bf6d5c9b2a4b4aef1a55c0e3b71a /dev-util/gitlab-runner
parentdev-util/ruff: drop 0.6.0 (diff)
downloadgentoo-997ae8e0f0b4ae5b164b214fb7e9238c75fcbdba.tar.gz
gentoo-997ae8e0f0b4ae5b164b214fb7e9238c75fcbdba.tar.bz2
gentoo-997ae8e0f0b4ae5b164b214fb7e9238c75fcbdba.zip
dev-util/gitlab-runner: add 17.3.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-17.3.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index a63754d4e35c..f06fd1db2227 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -6,3 +6,5 @@ DIST gitlab-runner-17.1.1-deps.tar.xz 86652408 BLAKE2B 2dd00989f0b0cf3802ed8c018
DIST gitlab-runner-17.1.1.tar.bz2 1373122 BLAKE2B 01763963374705f22d1a396785838aa4fdc3eb2a2343264824e4dda606fd190875b34f52e128fd581044fe83689d600c74bf42fedd1347e58dced044f1168462 SHA512 161661fecb415267bb580cba1fb6be12b6adc58a0a6a03e75f7ea8e3dc3f6ca6169ca90e202444e7923444cb17d5e3a7007aec526666ead8ee5c962c04228ce7
DIST gitlab-runner-17.2.1-deps.tar.xz 86661500 BLAKE2B 96700ef116677e2fa0d2233475906563b54d7d422ff25612439f0b6530592e24f472b9645d4faff4dd2f98ea37d0f8ad1242ee7ef532a6d7204d582925a50ae3 SHA512 f40317a3d3e9c873c8ba486d6b4c82d233166fc175ed7f8e6563d8a217d80b806f730b4f22e5879568528035961a6fc120b87ce8e9ea2eb9232ba8623b7e407e
DIST gitlab-runner-17.2.1.tar.bz2 1378845 BLAKE2B 649217da0c358e8db87758c72bd69897b1d9edd0b9e9d92c9a42ce7b39b5fa8bef7a07faf107584d90aae8ce292e0625b2a021294cd9b8cff73c02d086a5cda7 SHA512 3c14643da0884bc6bdf1eebfababb1ffa7d2ecf93ec1b0e708aef143b8a9519bc7d27fb6a3fdf6f6fb5b04511a8f1cfd9622c9c5db4365c879dc30c8a4d59cb6
+DIST gitlab-runner-17.3.0-deps.tar.xz 86640820 BLAKE2B e2775c0f370c4dc13053e11b07a0217e76066f760af4499a2c4a439b43d3a931f059b7f8db8a6f99de9776e30d17fc734b87f91295bd098cf51e833fd80dcb23 SHA512 8cfc550044316f7102f92bf207b677d802fd978fbd338c3ee946a2d2f2376aa029ddbe16a61774cbf08cb736c30cab47d1b861b66d76015cda2ca1167e31ba98
+DIST gitlab-runner-17.3.0.tar.bz2 1383866 BLAKE2B 3e13880ca06225834fd4050efd4225034ae865bfe3b80833e2910bf4a5b705795d5af424ce0736af1f8166f95939aa57e1123339336aa9e41404e58aa1060e05 SHA512 f2a9150045a09b2fd746c3ac69d94beabd664d613f9ee539821edfc0c069aa4368f62381ed8c499ddcabf6bb8c8ecde2d23f5e4a26d816f2dd319d76a50f75f0
diff --git a/dev-util/gitlab-runner/gitlab-runner-17.3.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-17.3.0.ebuild
new file mode 100644
index 000000000000..d4d56e244f0e
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-17.3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=071ba93d
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}