summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-03-13 13:23:16 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-03-13 13:23:29 -0500
commit19c880889873d38a0e7f7f443d8cb8bda93fc349 (patch)
tree94efa5ccdef6399e833b16c7f4217f4c0a1f97db /dev-util/gitlab-runner
parentdev-util/gitlab-runner: add 16.7.1 (diff)
downloadgentoo-19c880889873d38a0e7f7f443d8cb8bda93fc349.tar.gz
gentoo-19c880889873d38a0e7f7f443d8cb8bda93fc349.tar.bz2
gentoo-19c880889873d38a0e7f7f443d8cb8bda93fc349.zip
dev-util/gitlab-runner: drop 16.7.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.7.0.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 05144f140c81..f1cc1033329f 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -1,5 +1,3 @@
-DIST gitlab-runner-16.7.0-deps.tar.xz 236174584 BLAKE2B 54372f6f817fdbcb208924c563c07300911cde664035f50f0324785cadbacaa353cdb532045f4b41a6b026f80fc440f8756260d7524094e6e777835db5388d89 SHA512 95c32c55a6bde15db4ea9c82cb76952f4b51b98a6b3e02047e51ae9510e1d9189248d44545f665c7db588e26c58f20c6ef13c7692376a07c4afcf98cf96eae26
-DIST gitlab-runner-16.7.0.tar.bz2 1349700 BLAKE2B 3371e91a8881b9b0f9ada5ed05509db2b8052e4570aeabe7555474450897815ebd7bd81cbc979e75cd871f1d61ded0670ebcf91890b2a57de0b7c771698f6739 SHA512 21f1ecdf181dd7d62d92709e2efd9a9373e0c7a807ddba035becdc8b98b8f2a18bc3ac21f23af3c060e8b3e650b81c213c93068345f19789df904837fd00e4d5
DIST gitlab-runner-16.7.1-deps.tar.xz 87336740 BLAKE2B 46751e0365b20b0ae777b1e562221b292f67a06275c4728c4718cf405b582e0a84d97ef83a61e238b54d4a9b96ae0a8afc7455f9a87174fb327d6056922dea0f SHA512 d0cddf954e4cf6229a8b6d44ffe0b03234b1e63ecb464d902138912b8309e204e8add3ec6df41461df05a85b5aa263dd4fee8f82c00ef00ac16cc542fb218925
DIST gitlab-runner-16.7.1.tar.bz2 1349267 BLAKE2B e555b26bab2b0fdfd9367c27373dfb26edd57ba9eec77789c07cfc5760f5446ee045a62863549181df8ef18168f25250215d1285c27ec6c7be4291e260b00965 SHA512 e2426b6a96d4ec6c001aaec639e8134bd04e560b23cb06de277e7330feb117fe9c6888a9976211f587f6077943e42056898cb7b4996bcdd0b56ac56f329605d2
DIST gitlab-runner-16.8.1-deps.tar.xz 236213628 BLAKE2B b270aa8f285c1c568c303832b1600b50425e2e5b94f18a53ac1cd4afe35e2279fc81c3ac0ad671959f8833d0b55d2e9057e4f8222f274a5224af0440b876b75f SHA512 2c7fa171624d05617777b442d3fd4870e1180231df5f34005b388de5d0f3ead2297599f45a5d7ad05d84abf054507263d96c673cb3f3e3ff5a734891a2771727
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.7.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.7.0.ebuild
deleted file mode 100644
index 7bf43b214f04..000000000000
--- a/dev-util/gitlab-runner/gitlab-runner-16.7.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd tmpfiles
-
-# make sure this gets updated for every bump
-GIT_COMMIT=102c81ba
-
-DESCRIPTION="The official GitLab Runner, written in Go"
-HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
-SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv"
-
-COMMON_DEPEND="acct-group/gitlab-runner
- acct-user/gitlab-runner"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-BDEPEND="dev-go/gox"
-
-DOCS=( docs CHANGELOG.md README.md config.toml.example )
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_compile() {
- emake \
- BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
- GOX="${EPREFIX}/usr/bin/gox" \
- REVISION=${GIT_COMMIT} \
- VERSION=${PV} \
- runner-bin-host
-}
-
-src_test() {
- CI=0 ego test
-}
-
-src_install() {
- dobin out/binaries/gitlab-runner
- einstalldocs
-
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
- newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
- keepdir /{etc,var/log}/${PN}
- fperms 0700 /{etc,var/log}/gitlab-runner
- fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
-}
-
-pkg_postinst() {
- tmpfiles_process gitlab-runner.conf
- [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
- elog
- elog "To use the runner, you need to register it with this command:"
- elog "# gitlab-runner register"
- elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
-}