summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/flawfinder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/flawfinder')
-rw-r--r--dev-util/flawfinder/Manifest2
-rw-r--r--dev-util/flawfinder/files/flawfinder-1.27-whitespace-traceback.patch17
-rw-r--r--dev-util/flawfinder/flawfinder-1.27-r2.ebuild31
-rw-r--r--dev-util/flawfinder/flawfinder-1.31.ebuild30
-rw-r--r--dev-util/flawfinder/metadata.xml8
5 files changed, 88 insertions, 0 deletions
diff --git a/dev-util/flawfinder/Manifest b/dev-util/flawfinder/Manifest
new file mode 100644
index 000000000000..5b66bcc6cf20
--- /dev/null
+++ b/dev-util/flawfinder/Manifest
@@ -0,0 +1,2 @@
+DIST flawfinder-1.27.tar.gz 123086 SHA256 8825a9742db29da329ec57861d702a744452f84fbc02f617c037becafaf6f546 SHA512 97f32f20761e361ee5ccda908c2dab489d352ae52438d3f226b784487e732c8a92fcc3b14d3cfe6328e567b6d23501911908612c40fa568010b8d42a302c374d WHIRLPOOL 9f0aaa6cfb4daf5a442754ad422367581e39ec8d73ea87964236554c3b37d075d036146f6af2ce1983e3d0c556e15c29c948d53de3cdf9c8837d3386878795a1
+DIST flawfinder-1.31.tar.gz 174148 SHA256 bca7256fdf71d778eb59c9d61fc22b95792b997cc632b222baf79cfc04887c30 SHA512 880919a05dbf0e29055f052b88c8bbfd403105504749bc65fb17675e6ebe0d84f9cd367e7a6efc68dc0d9209e0938185da4718b70f484007c507fe96b83e0355 WHIRLPOOL 4afd25adf50a1457fb678e84104182bcefbd88bbe3ec5cdc4f44136d5e3dce13da5911acae2edde15cf4fa6193af81a31ab4c2f9daf3463fac0f67a5a5c1c525
diff --git a/dev-util/flawfinder/files/flawfinder-1.27-whitespace-traceback.patch b/dev-util/flawfinder/files/flawfinder-1.27-whitespace-traceback.patch
new file mode 100644
index 000000000000..fcd60f916acd
--- /dev/null
+++ b/dev-util/flawfinder/files/flawfinder-1.27-whitespace-traceback.patch
@@ -0,0 +1,17 @@
+From: Robert Buchholz <rbu@gentoo.org>
+Subject: Fix IndexError that occurs when there is whitespace at the end of the file
+
+Origin: vendor, http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-util/flawfinder/files/flawfinder-1.27-whitespace-traceback.patch
+Bug: http://sourceforge.net/tracker/index.php?func=detail&aid=1834743&group_id=186989&atid=919499
+
+--- flawfinder.orig 2009-09-29 13:55:15.433911571 +0200
++++ flawfinder 2009-09-29 13:56:03.114786154 +0200
+@@ -1299,6 +1299,8 @@
+ m = p_whitespace.match(text,i)
+ if m:
+ i = m.end(0)
++ if i >= len(text):
++ break
+
+ c = text[i]
+ if linebegin: # If at beginning of line, see if #include is there.
diff --git a/dev-util/flawfinder/flawfinder-1.27-r2.ebuild b/dev-util/flawfinder/flawfinder-1.27-r2.ebuild
new file mode 100644
index 000000000000..ea5100233851
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-1.27-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="http://www.dwheeler.com/flawfinder/"
+SRC_URI="http://www.dwheeler.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/flawfinder-1.27-whitespace-traceback.patch
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ChangeLog INSTALL.txt README announcement
+ dodoc flawfinder.pdf
+ python_convert_shebangs 2 "${ED}"usr/bin/flawfinder
+}
diff --git a/dev-util/flawfinder/flawfinder-1.31.ebuild b/dev-util/flawfinder/flawfinder-1.31.ebuild
new file mode 100644
index 000000000000..38027e1b2d56
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-1.31.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="http://www.dwheeler.com/flawfinder/"
+SRC_URI="http://www.dwheeler.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc announcement ChangeLog README announcement
+ dodoc flawfinder.pdf
+ python_fix_shebang "${ED}"usr/bin/flawfinder
+}
diff --git a/dev-util/flawfinder/metadata.xml b/dev-util/flawfinder/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/dev-util/flawfinder/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>