summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2020-06-27 17:04:30 -0700
committerBrian Dolbec <dolsen@gentoo.org>2020-06-27 17:46:21 -0700
commit7555fccc70c0039a08f5e1f468c77c5ce10980ef (patch)
tree8801975a41cf118173eb9e4003d2660ab795aff3 /dev-util/buildbot-console-view
parentdev-util/buildbot-waterfall-view: Version bump (diff)
downloadgentoo-7555fccc70c0039a08f5e1f468c77c5ce10980ef.tar.gz
gentoo-7555fccc70c0039a08f5e1f468c77c5ce10980ef.tar.bz2
gentoo-7555fccc70c0039a08f5e1f468c77c5ce10980ef.zip
dev-util/buildbot-console-view: Version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-console-view')
-rw-r--r--dev-util/buildbot-console-view/Manifest1
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-2.8.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/Manifest b/dev-util/buildbot-console-view/Manifest
index 397c5f463ba7..f3b713b72e19 100644
--- a/dev-util/buildbot-console-view/Manifest
+++ b/dev-util/buildbot-console-view/Manifest
@@ -1,2 +1,3 @@
DIST buildbot-console-view-2.7.0.tar.gz 17939 BLAKE2B 1ea1848f0276bb7ef4adaf63dbe290ad5769689b15898682deed61e9797eb4945047dd26d492b118b75314621bf2777b77e992f1a3129e413c01c17b27b680c1 SHA512 22875fc4c3440892147db7c6ef1eba165a29f4ccd3583827394d0195c72dc8ec3d31940587e4da1f0133def074c72f87bc23bb210189a0e0d028c0be52368107
DIST buildbot-console-view-2.8.0.tar.gz 18022 BLAKE2B 455ca2a1caed7d55a26d4b176cddf1a571f411dab191eda890698aa1d5150539c620ae90b2d1c5ab70cd47589466ca4534e2da1d1e73ab388761319f81434b39 SHA512 9344021b774f5cecf39384cff869ec0c9778630ec0015d654218ad03d83a18849e1b144dae74f7c85296efac6bbc767f387a1aa4b5271f3996c7e1b177f3b735
+DIST buildbot-console-view-2.8.2.tar.gz 17575 BLAKE2B e036429dd40fdfdadd65a10d4f6fc025b00d9a61153aecd4f31e0c6c133ba1e546b1c810254ec1fb83913cd4434db223c3cd782481ef5785ec48162a2f111682 SHA512 dbec358933865aa79ad86754ef454d89fa369fc64f3df54eb079c0f1ebadb027131d4bd7ac14dd29a16d34aa416e21f90cbecc873944a7ab8ef7da637e20c999
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-2.8.2.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-2.8.2.ebuild
new file mode 100644
index 000000000000..461db8d8fd20
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-2.8.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-console-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}