summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/build
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/build')
-rw-r--r--dev-util/build/Manifest1
-rw-r--r--dev-util/build/build-0.3.9.ebuild30
-rw-r--r--dev-util/build/metadata.xml8
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/build/Manifest b/dev-util/build/Manifest
new file mode 100644
index 000000000000..d93505d427cf
--- /dev/null
+++ b/dev-util/build/Manifest
@@ -0,0 +1 @@
+DIST build-0.3.9.tar.bz2 71545 SHA256 158a26af751dfc00d9b88021305ea74935542a9f970d1ac7e805cd239a3400b5 SHA512 295350dfd91265481cfe956a1edfadaf46c4eef01d344a4ed8df7124fbda8eb58503836fa7810faa1f5f3d5fc5e110854496a782df7520fbcc1c1cba3c1f3586 WHIRLPOOL e0b12a2341ec4173aca81dad35e39de60e96e8dd321d900c5670c5c66dcfe7676d2a1a4383adefd7fa76138c891a652d32324e4afbe6082fa6aabdfbac12a8f8
diff --git a/dev-util/build/build-0.3.9.ebuild b/dev-util/build/build-0.3.9.ebuild
new file mode 100644
index 000000000000..9261a4a280c7
--- /dev/null
+++ b/dev-util/build/build-0.3.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit versionator
+
+DESCRIPTION="A massively-parallel software build system implemented on top of GNU make"
+HOMEPAGE="http://kolpackov.net/projects/build/"
+SLOT="$(get_version_component_range 1-2)"
+SRC_URI="http://www.codesynthesis.com/download/${PN}/${SLOT}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ emake install_prefix="${D}/usr" install
+
+ dodoc documentation/[[:upper:]]*
+ dohtml -A xhtml documentation/*.{css,xhtml}
+
+ if use examples ; then
+ # preserving symlinks in the examples
+ cp -dpR examples "${D}/usr/share/doc/${PF}"
+ fi
+}
diff --git a/dev-util/build/metadata.xml b/dev-util/build/metadata.xml
new file mode 100644
index 000000000000..75dd2ca7d302
--- /dev/null
+++ b/dev-util/build/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>