summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-04-23 12:49:56 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-04-23 14:01:44 +0200
commit492806073fd9e8d93c1623c824e222a24800309a (patch)
tree465c5308a32e455b70a3a4e3e02b76011be2b813 /dev-texlive
parentapp-arch/innoextract: fix build w/ boost-1.85.0 (diff)
downloadgentoo-492806073fd9e8d93c1623c824e222a24800309a.tar.gz
gentoo-492806073fd9e8d93c1623c824e222a24800309a.tar.bz2
gentoo-492806073fd9e8d93c1623c824e222a24800309a.zip
dev-texlive/texlive-context: install context scripts
Closes: https://bugs.gentoo.org/930400 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-texlive')
-rw-r--r--dev-texlive/texlive-context/texlive-context-2023_p69108-r2.ebuild (renamed from dev-texlive/texlive-context/texlive-context-2023_p69108-r1.ebuild)26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-texlive/texlive-context/texlive-context-2023_p69108-r1.ebuild b/dev-texlive/texlive-context/texlive-context-2023_p69108-r2.ebuild
index 2619f7d82809..3c02f6e2eb0c 100644
--- a/dev-texlive/texlive-context/texlive-context-2023_p69108-r1.ebuild
+++ b/dev-texlive/texlive-context/texlive-context-2023_p69108-r2.ebuild
@@ -74,12 +74,38 @@ DEPEND="
>=app-text/texlive-core-2023[xetex,luajittex?]
"
+TEXLIVE_MODULE_BINSCRIPTS="
+ texmf-dist/scripts/context/stubs-mkiv/unix/contextjit
+ texmf-dist/scripts/context/stubs-mkiv/unix/luatools
+ texmf-dist/scripts/context/stubs-mkiv/unix/mtxrunjit
+
+ texmf-dist/scripts/context/stubs/unix/texexec
+ texmf-dist/scripts/context/stubs/unix/texmfstart
+"
+
src_prepare() {
default
# No need to install these .exe
rm -rf texmf-dist/scripts/context/stubs/{mswin,win64} || die
}
+src_install() {
+ texlive-module_src_install
+
+ local mtxrun=/usr/share/texmf-dist/scripts/context/lua/mtxrun.lua
+ fperms 755 "${mtxrun}"
+ newbin - mtxrun <<-EOF
+ #!/bin/sh
+ export TEXMF_DIST="${EPREFIX}/usr/share/texmf-dist"
+ exec ${mtxrun} "\$@"
+EOF
+
+ newbin - context <<-EOF
+ #!/bin/sh
+ exec mtxrun --script context "\$@"
+EOF
+}
+
TL_MODULE_INFORMATION="For using ConTeXt mkII simply use 'texexec' to generate
your documents.
If you plan to use mkIV and its 'context' command to generate your documents,