summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-28 23:24:44 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-28 23:25:50 +0100
commit351c1b5a626680968e5f4e0330000b1f7f32d871 (patch)
treeb95bf130c658668810e9ab864d9d03a920e45cbb /dev-scheme
parentapp-emulation/firecracker-bin: Bump to 0.25.2 (diff)
downloadgentoo-351c1b5a626680968e5f4e0330000b1f7f32d871.tar.gz
gentoo-351c1b5a626680968e5f4e0330000b1f7f32d871.tar.bz2
gentoo-351c1b5a626680968e5f4e0330000b1f7f32d871.zip
dev-scheme/owl-lisp: new package; add version 0.2 and live
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/owl-lisp/Manifest1
-rw-r--r--dev-scheme/owl-lisp/metadata.xml20
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-0.2.ebuild42
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-9999.ebuild42
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-scheme/owl-lisp/Manifest b/dev-scheme/owl-lisp/Manifest
new file mode 100644
index 000000000000..0a54360a4209
--- /dev/null
+++ b/dev-scheme/owl-lisp/Manifest
@@ -0,0 +1 @@
+DIST owl-v0.2.tar.gz 515574 BLAKE2B 054a06d33554cc31f5e1c756bf3ff5ea4fb5cec220048fb939aa9dcd19c586cef54ae8ddc80e1ee8befedfa2e42fc1bf9ea4bcfe37e6743154ff678346444e87 SHA512 f0dc4badc84be1ebd1ad8f6a84c8fc292449b0f66a9416f202f9010e89aa2971c6470599173db67bf3db3e4b6a61d777ee369eda76fa7c42114748e8fe48b7b2
diff --git a/dev-scheme/owl-lisp/metadata.xml b/dev-scheme/owl-lisp/metadata.xml
new file mode 100644
index 000000000000..904d4e58388f
--- /dev/null
+++ b/dev-scheme/owl-lisp/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>scheme@gentoo.org</email>
+ <name>Gentoo Scheme Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Owl Lisp is a simple programming language. The main motivation for
+ writing it was to get a portable system for writing standalone
+ programs in a subjectively pleasant dialect of LISP, which in this
+ case means a minimal core language and runtime, purely functional
+ operation and support for asynchronous evaluation.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/owl-lisp/owl/-/issues</bugs-to>
+ <remote-id type="gitlab">owl-lisp/owl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild b/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild
new file mode 100644
index 000000000000..95d2e9242438
--- /dev/null
+++ b/dev-scheme/owl-lisp/owl-lisp-0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Purely functional dialect of Scheme"
+HOMEPAGE="https://haltp.org/posts/owl.html"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/owl-lisp/owl.git"
+else
+ SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v0.2/owl-v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/owl-v${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ sed -i 's|make bin/vm|$(MAKE) bin/vm|g' ./Makefile || die
+}
+
+src_compile(){
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" owl
+}
+
+src_install() {
+ einstalldocs
+
+ dobin ./bin/ol
+ newbin ./bin/vm ovm
+
+ doman ./doc/*.1
+}
diff --git a/dev-scheme/owl-lisp/owl-lisp-9999.ebuild b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
new file mode 100644
index 000000000000..95d2e9242438
--- /dev/null
+++ b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Purely functional dialect of Scheme"
+HOMEPAGE="https://haltp.org/posts/owl.html"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/owl-lisp/owl.git"
+else
+ SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v0.2/owl-v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/owl-v${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ sed -i 's|make bin/vm|$(MAKE) bin/vm|g' ./Makefile || die
+}
+
+src_compile(){
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" owl
+}
+
+src_install() {
+ einstalldocs
+
+ dobin ./bin/ol
+ newbin ./bin/vm ovm
+
+ doman ./doc/*.1
+}