summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-sdl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-sdl')
-rw-r--r--dev-ruby/ruby-sdl/Manifest1
-rw-r--r--dev-ruby/ruby-sdl/metadata.xml13
-rw-r--r--dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r1.ebuild69
-rw-r--r--dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r2.ebuild69
4 files changed, 152 insertions, 0 deletions
diff --git a/dev-ruby/ruby-sdl/Manifest b/dev-ruby/ruby-sdl/Manifest
new file mode 100644
index 000000000000..6760a59b34c7
--- /dev/null
+++ b/dev-ruby/ruby-sdl/Manifest
@@ -0,0 +1 @@
+DIST ruby-sdl-2.1.2.tar.gz 178105 SHA256 4436e3e6b10e7f5adbf5c5e62325366155e7dee52db8da233f3137149c448c64 SHA512 1ddae367fb4145cc8142edbf3c61acaf56604054f710ac37cadb8d04f93db24fc3595c1bc8e0fb5f330aabc815884f31b5f2a39c0108026fca442fc0b3bc2807 WHIRLPOOL cf121d5e2a4619f913047854555000dfdf767cf1b103ab2e93de023da5b89fdd22beb19c28780a59fcd6298c0be02308394691fd81772e331347e33ef85b4f58
diff --git a/dev-ruby/ruby-sdl/metadata.xml b/dev-ruby/ruby-sdl/metadata.xml
new file mode 100644
index 000000000000..f7a74de48806
--- /dev/null
+++ b/dev-ruby/ruby-sdl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <use>
+ <flag name="image">Enable <pkg>media-libs/sdl-image</pkg> support</flag>
+ <flag name="mixer">Enable <pkg>media-libs/sdl-mixer</pkg> support</flag>
+ <flag name="sge">Enable sdl-sge support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ohai/rubysdl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r1.ebuild b/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..6ef368e29a8c
--- /dev/null
+++ b/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+inherit eutils ruby-ng
+
+RELEASE="rel-${PV//./-}"
+RUBY_S="rubysdl-${RELEASE}"
+
+DESCRIPTION="Ruby/SDL: Ruby bindings for SDL"
+HOMEPAGE="http://www.kmc.gr.jp/~ohai/rubysdl.en.html"
+SRC_URI="https://github.com/ohai/rubysdl/archive/${RELEASE}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+IUSE="image mixer truetype mpeg sge"
+
+CDEPEND="
+ >=media-libs/libsdl-1.2.5
+ truetype? ( >=media-libs/sdl-ttf-2.0.6 )
+ image? ( >=media-libs/sdl-image-1.2.2 )
+ mixer? ( >=media-libs/sdl-mixer-1.2.4 )
+ mpeg? ( >=media-libs/smpeg-0.4.4-r1 )
+ sge? ( media-libs/sge )"
+DEPEND="${DEPEND} ${CDEPEND}"
+RDEPEND="${RDEPEND} ${CDEPEND}"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 || die "emake failed"
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install || die "einstall failed"
+}
+
+all_ruby_install() {
+ dodoc README.en README.ja NEWS.en NEWS.ja
+ insinto /usr/share/doc/${P}/doc
+ doins doc-en/*
+ insinto /usr/share/doc/${P}/sample
+ doins sample/*
+}
+
+pkg_postinst () {
+ if ! use image || ! use mixer || ! use truetype || ! use mpeg || ! use sge; then
+ echo ""
+ ewarn "If any of the following packages are not installed, Ruby/SDL"
+ ewarn "will be missing some functionality. This is ok, but may"
+ ewarn "cause errors in Ruby/SDL programs that need these libraries:"
+ ewarn ""
+ ewarn "\tmedia-libs/sdl-image\tImage loading (PNG, JPEG, etc.)"
+ ewarn "\tmedia-libs/sdl-mixer\tSound mixing"
+ ewarn "\tmedia-libs/sdl-ttf\tTrueType Fonts"
+ ewarn "\tmedia-libs/sge\t\tVarious cool graphics extensions"
+ ewarn "\tmedia-libs/smpeg\tMPEG playback (including mp3)"
+ ewarn ""
+ ewarn "If you need the functionality offered by these libraries,"
+ ewarn "emerge the desired libraries, then re-emerge dev-ruby/rubysdl"
+ echo ""
+ fi
+}
diff --git a/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r2.ebuild b/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r2.ebuild
new file mode 100644
index 000000000000..4b2868c0eedd
--- /dev/null
+++ b/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit eutils ruby-ng
+
+RELEASE="rel-${PV//./-}"
+RUBY_S="rubysdl-${RELEASE}"
+
+DESCRIPTION="Ruby/SDL: Ruby bindings for SDL"
+HOMEPAGE="http://www.kmc.gr.jp/~ohai/rubysdl.en.html"
+SRC_URI="https://github.com/ohai/rubysdl/archive/${RELEASE}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="image mixer truetype mpeg sge"
+
+CDEPEND="
+ >=media-libs/libsdl-1.2.5
+ truetype? ( >=media-libs/sdl-ttf-2.0.6 )
+ image? ( >=media-libs/sdl-image-1.2.2 )
+ mixer? ( >=media-libs/sdl-mixer-1.2.4 )
+ mpeg? ( >=media-libs/smpeg-0.4.4-r1 )
+ sge? ( media-libs/sge )"
+DEPEND="${DEPEND} ${CDEPEND}"
+RDEPEND="${RDEPEND} ${CDEPEND}"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 || die "emake failed"
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install || die "einstall failed"
+}
+
+all_ruby_install() {
+ dodoc README.en README.ja NEWS.en NEWS.ja
+ insinto /usr/share/doc/${P}/doc
+ doins doc-en/*
+ insinto /usr/share/doc/${P}/sample
+ doins sample/*
+}
+
+pkg_postinst () {
+ if ! use image || ! use mixer || ! use truetype || ! use mpeg || ! use sge; then
+ echo ""
+ ewarn "If any of the following packages are not installed, Ruby/SDL"
+ ewarn "will be missing some functionality. This is ok, but may"
+ ewarn "cause errors in Ruby/SDL programs that need these libraries:"
+ ewarn ""
+ ewarn "\tmedia-libs/sdl-image\tImage loading (PNG, JPEG, etc.)"
+ ewarn "\tmedia-libs/sdl-mixer\tSound mixing"
+ ewarn "\tmedia-libs/sdl-ttf\tTrueType Fonts"
+ ewarn "\tmedia-libs/sge\t\tVarious cool graphics extensions"
+ ewarn "\tmedia-libs/smpeg\tMPEG playback (including mp3)"
+ ewarn ""
+ ewarn "If you need the functionality offered by these libraries,"
+ ewarn "emerge the desired libraries, then re-emerge dev-ruby/rubysdl"
+ echo ""
+ fi
+}