summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-06-17 06:51:56 +0200
committerHans de Graaff <graaff@gentoo.org>2023-06-17 06:53:32 +0200
commit4ab5a448579f5e70d21e1cd944ee3a25f292c62d (patch)
tree0d42e52f3863aec5afadb58e21462509ee5ab07e /dev-ruby/rdiscount
parentdev-ruby/rcairo: add 1.17.12 (diff)
downloadgentoo-4ab5a448579f5e70d21e1cd944ee3a25f292c62d.tar.gz
gentoo-4ab5a448579f5e70d21e1cd944ee3a25f292c62d.tar.bz2
gentoo-4ab5a448579f5e70d21e1cd944ee3a25f292c62d.zip
dev-ruby/rdiscount: add 2.2.7.1
Closes: https://bugs.gentoo.org/883113 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/Manifest1
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.2.7.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/rdiscount/Manifest b/dev-ruby/rdiscount/Manifest
index 0fd7a2cc8d11..b478c52086e3 100644
--- a/dev-ruby/rdiscount/Manifest
+++ b/dev-ruby/rdiscount/Manifest
@@ -1 +1,2 @@
+DIST rdiscount-2.2.7.1.gem 74240 BLAKE2B 06779a601c8d13b90f5d9fb1c38712431671eab1cb2ef012dee284ddb6da254a0c788f16295438913d68f3641db2ec48c7cea3bade4f36fdc55b7a6049119fd4 SHA512 e67bbbb7f19ef14a729642e2059f0920b65a3f254507204955ab6d34529ade643ee7adecc3db2c61ca5462d266f88ea336bd228401e3cd0fad98e2e7763dd8d3
DIST rdiscount-2.2.7.gem 73728 BLAKE2B 0d63372c3e2f4fa1efeef12ec4f8a2b12b9fccd7506ac6609d7e8fea958e04cfa1cc96a484ffba17d643838705d52c1557604ca015fded282ec860a7fc2481a5 SHA512 4f60dc0dbfb6b8f95f80d577c872c2a747d7d15e9fc1f1bd3640f1207a5d262068754dcb6d7b53348fd69de20b85534a390aace35d1eff31112bfbe0f77569d1
diff --git a/dev-ruby/rdiscount/rdiscount-2.2.7.1.ebuild b/dev-ruby/rdiscount/rdiscount-2.2.7.1.ebuild
new file mode 100644
index 000000000000..2bdd888ed424
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.2.7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/davidfstr/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+
+ # Remove obsolete -rubygems argument, bug 775377
+ sed -i -e '/-rubygems/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}