summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-10-21 10:57:49 +0200
committerHans de Graaff <graaff@gentoo.org>2018-10-21 10:58:15 +0200
commit53efb60932d6f627fc8f6e036d479656ee04fb0f (patch)
treecdf83875df281460099d64e3c87466185a7b4880 /dev-ruby/google-protobuf
parentdev-ruby/dalli: cleanup (diff)
downloadgentoo-53efb60932d6f627fc8f6e036d479656ee04fb0f.tar.gz
gentoo-53efb60932d6f627fc8f6e036d479656ee04fb0f.tar.bz2
gentoo-53efb60932d6f627fc8f6e036d479656ee04fb0f.zip
dev-ruby/google-protobuf: initial import of 3.6.1
New dependency for cucumber-messages, which in turn is a new dependency for dev-ruby/gherkin. Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/google-protobuf')
-rw-r--r--dev-ruby/google-protobuf/Manifest1
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.6.1.ebuild37
-rw-r--r--dev-ruby/google-protobuf/metadata.xml8
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/google-protobuf/Manifest b/dev-ruby/google-protobuf/Manifest
new file mode 100644
index 000000000000..77f6714b99f4
--- /dev/null
+++ b/dev-ruby/google-protobuf/Manifest
@@ -0,0 +1 @@
+DIST google-protobuf-3.6.1-ruby.tar.gz 4485582 BLAKE2B 546c49759df784018459809b9db692c5c94aef5d717183af5cd9edd96b4c658e759f23950cdcd5dddceaaad06ea1de2a2357b9fa8c496ed5d538fc5920174da0 SHA512 1bc175d24b49de1b1e41eaf39598194e583afffb924c86c8d2e569d935af21874be76b2cbd4d9655a1d38bac3d4cd811de88bc2c72d81bad79115e69e5b0d839
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.6.1.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.6.1.ebuild
new file mode 100644
index 000000000000..bc07705fb0cf
--- /dev/null
+++ b/dev-ruby/google-protobuf/google-protobuf-3.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protocol Buffers are Google's data interchange format"
+HOMEPAGE="https://developers.google.com/protocol-buffers"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
+RUBY_S="protobuf-${PV}/ruby"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" test? ( dev-libs/protobuf )"
+
+each_ruby_prepare() {
+ sed -i -e 's:../src/protoc:protoc: ; /^task :build/ s/:compile,//' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/google/protobuf_c extconf.rb
+}
+
+each_ruby_compile() {
+ emake -Cext/google/protobuf_c V=1
+ cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
+}
diff --git a/dev-ruby/google-protobuf/metadata.xml b/dev-ruby/google-protobuf/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/google-protobuf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>