summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-11-19 23:24:22 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2020-11-19 23:28:53 -0800
commit658d2816b86ba1a56638e4e1ae3f2b1d3e11f7c5 (patch)
treec1b5bcdbcee4fb271ede0da105d4d5fadba254cc /dev-ruby/fast_gettext/fast_gettext-1.1.2.ebuild
parentapp-admin/r10k: bump; many versions for fast testing of undeclared upstream d... (diff)
downloadgentoo-658d2816b86ba1a56638e4e1ae3f2b1d3e11f7c5.tar.gz
gentoo-658d2816b86ba1a56638e4e1ae3f2b1d3e11f7c5.tar.bz2
gentoo-658d2816b86ba1a56638e4e1ae3f2b1d3e11f7c5.zip
dev-ruby/fast_gettext: re-add 1.1.2 to satify Gem dep of gettext-setup
gettext-setup, r10k & fast_gettext have deps that pin 1.1.x of fast_gettext for the moment, so re-add a suitable version: s.add_dependency 'fast_gettext', '~> 1.1.0' s.add_dependency 'gettext', ['>= 3.0.2', '< 3.3.0'] Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-ruby/fast_gettext/fast_gettext-1.1.2.ebuild')
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-1.1.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/fast_gettext/fast_gettext-1.1.2.ebuild b/dev-ruby/fast_gettext/fast_gettext-1.1.2.ebuild
new file mode 100644
index 000000000000..e398213311e4
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-1.1.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Re-added to support gettext-setup that specifies ~>1.1.0
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5x faster, 560x less memory, clean namespace and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler and bump from Gemfile since they are not needed for tests.
+ sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
+
+ # Avoid unneeded dependency on git and development dependencies.
+ sed -e '/git ls-files/ s:^:#:' \
+ -e '/\(wwtd\|bump\|sqlite3\|activerecord\|i18n\)/ s:^:#:' \
+ -i fast_gettext.gemspec || die
+
+ # Avoid a test dependency on activerecord since this is now in the
+ # dependency tree for app-admin/puppet and many arches don't have
+ # rails keyworded.
+ sed -i -e '/active_record/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/fast_gettext/translation_repository/db_spec.rb || die
+ sed -i -e '/works with DB repository/,/^ end/ s:^:#:' spec/fast_gettext/storage_spec.rb || die
+ sed -i -e '/with i18n loaded/,/^ end/ s:^:#:' spec/fast_gettext/vendor/string_spec.rb || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}