summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-22 15:19:15 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-22 15:22:29 +0100
commite624650e7ccfd1000e29af5648684127c66dae85 (patch)
tree4ff17625586b828b2cabc63c7777c93be8d3709d /dev-ruby/evented-spec
parentdev-ruby/ruby-mp3info: cleanup (diff)
downloadgentoo-e624650e7ccfd1000e29af5648684127c66dae85.tar.gz
gentoo-e624650e7ccfd1000e29af5648684127c66dae85.tar.bz2
gentoo-e624650e7ccfd1000e29af5648684127c66dae85.zip
dev-ruby/evented-spec: EAPI 8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/evented-spec')
-rw-r--r--dev-ruby/evented-spec/evented-spec-0.9.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/evented-spec/evented-spec-0.9.0-r1.ebuild b/dev-ruby/evented-spec/evented-spec-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..01f4fa2260e8
--- /dev/null
+++ b/dev-ruby/evented-spec/evented-spec-0.9.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A set of helpers to help you test your asynchronous code"
+HOMEPAGE="https://github.com/ruby-amqp/evented-spec"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Tests require a running AMQP server and AMQP installed. Since
+# currently AMQP is the only package using evented-spec we just skip the
+# tests here altogether to avoid circular dependencies.
+RESTRICT="test"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}