summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-06 10:54:03 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-06 12:04:23 +0200
commit38e0d87884f3805c04f074b4b70b3f0de06baa5b (patch)
treeccc67874bd5e2fda554a3788edc05b91d2743640 /dev-ruby/date_validator
parentdev-ruby/database_cleaner: enable ruby30 and disable ruby25 (diff)
downloadgentoo-38e0d87884f3805c04f074b4b70b3f0de06baa5b.tar.gz
gentoo-38e0d87884f3805c04f074b4b70b3f0de06baa5b.tar.bz2
gentoo-38e0d87884f3805c04f074b4b70b3f0de06baa5b.zip
dev-ruby/date_validator: drop 0.10.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/date_validator')
-rw-r--r--dev-ruby/date_validator/Manifest1
-rw-r--r--dev-ruby/date_validator/date_validator-0.10.0.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/date_validator/Manifest b/dev-ruby/date_validator/Manifest
index 4259f905a6de..30b094912f1b 100644
--- a/dev-ruby/date_validator/Manifest
+++ b/dev-ruby/date_validator/Manifest
@@ -1,3 +1,2 @@
-DIST date_validator-0.10.0.gem 12800 BLAKE2B 0cbb11e70cb72a1203c2ec33581d4ed48be346af6998faa89e4323c8c6bf70b5c979b55bc79630153a940697c89ce140eb511538cd55adb0f12566f2f1a317a9 SHA512 4348835898ebfe311a8ea456adc10f7bbfd1dc21daf2678e32b1615ba3eef3d36671f67f533109882f40516c836f23d7e0a4072c9ecaa55a1b0eade0b6aa75b7
DIST date_validator-0.11.0.gem 12800 BLAKE2B ce45caa57bd1e29900ed0732bdbfbf81c68836de71efbf099bdc595a9b586872175960af40129af6d793ed5ce49ba222a3ca7d0172ef764ee02c88f4eae04e9e SHA512 269f3e234c8157a667c81d725497eafd21621cd35811f35707590242a3dc78065bd6dbe7b772a38761fdb8c95ae40f99976919444dac061f7bd2150fc9178afa
DIST date_validator-0.12.0.gem 12800 BLAKE2B 235434dbd7e4441698bc90e0dd37bf9e5b8f1f742424e8155876e677e5d7dbe7beb4edd2f7dda7dba2729a024dcda72ac816e4f6a7dd38fdfaa4ea79f21d078e SHA512 e7796375d6d6af2fc9ce6e7d6174d59bd35ddbac90c4e5b54b321e33ed25f3e816c58013fa61f2003724e87fc96495ce81c132d056c9c9331bd1a236eb7dec38
diff --git a/dev-ruby/date_validator/date_validator-0.10.0.ebuild b/dev-ruby/date_validator/date_validator-0.10.0.ebuild
deleted file mode 100644
index 8d4f4549e483..000000000000
--- a/dev-ruby/date_validator/date_validator-0.10.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_EXTRADOC="Readme.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-# if ever needed
-#GITHUB_USER="codegram"
-#GITHUB_PROJECT="${PN}"
-#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails"
-HOMEPAGE="https://github.com/codegram/date_validator"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/activemodel-3.0:*
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/minitest
- >=dev-ruby/tzinfo-0.3
- >=dev-ruby/activesupport-3.0
- )
- doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/git ls-files/d' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i \
- -e '/[Bb]undler/s/^/#/' Rakefile || die
- # Fix tests
- sed -i -e "1irequire 'active_support'; require 'active_support/core_ext/time/zones'" test/test_helper.rb || die
-}